{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-40560 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-40560 is a high-severity vulnerability in MIYAGAWA Starman, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40560 and fix it if it is affected.\n\nWhat it is: CVE-2026-40560 is a high-severity vulnerability in MIYAGAWA Starman, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40560 in the wild and no public exploit code.\n\nAffected product: MIYAGAWA Starman. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40560/ (Markdown: https://insights.sbomify.com/CVE-2026-40560/index.md)","id":"CVE-2026-40560","markdown":"https://insights.sbomify.com/CVE-2026-40560/index.md","name":"CVE-2026-40560","record":{"aliases":["DEBIAN-CVE-2026-40560","GHSA-gwjf-hg8j-jwvr","MGASA-2026-0119","UBUNTU-CVE-2026-40560","openSUSE-SU-2026:10757-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl HTTP server","requires_auth":"none","summary":"Starman allows HTTP request smuggling by mishandling conflicting headers, enabling attackers to bypass security controls via reverse proxies.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[{"product":"starman","vendor":"miyagawa"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Starman versions before 0.4018 for Perl allows HTTP Request Smuggling via Improper Header Precedence.\n\nStarman incorrectly prioritizes \"Content-Length\" over \"Transfer-Encoding: chunked\" when both headers are present in an HTTP request. Per RFC 7230 3.3.3, Transfer-Encoding must take precedence.\n\nAn attacker could exploit this to smuggle malicious HTTP requests via a front-end reverse proxy.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Starman versions before 0.4018 for Perl allows HTTP Request Smuggling via Improper Header Precedence","id":"CVE-2026-40560","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"Starlet versions through 0.31 for Perl allows HTTP Request Smuggling via Improper Header Precedence","id":"CVE-2026-40561"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.4018-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Starman","purl":"pkg:rpm/opensuse/perl-Starman\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10757-1"}],"prev":{"headline":"Apache Storm Prometheus Reporter vulnerable to Improper Certificate Validation via Global SSL Context Downgrade","id":"CVE-2026-40557"},"products":["Starman"],"published":"2026-04-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-29","vendors":["MIYAGAWA"]},"summary":"Starman allows HTTP request smuggling by mishandling conflicting headers, enabling attackers to bypass security controls via reverse proxies.","url":"https://insights.sbomify.com/CVE-2026-40560/"}