# CVE-2026-40574: OAuth2 Proxy has an Authorization Bypass in Email Domain Validation via Malformed Multi-@ Email Claims

> Attackers can bypass email domain restrictions in OAuth2 Proxy by using malformed email claims, allowing unauthorized access if email_domain enforcement is enabled.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** BIT-oauth2-proxy-2026-40574, GHSA-c5c4-8r6x-56w3, GO-2026-5314, MINI-3rhc-mr2m-h438, MINI-f472-6mpw-qvxp

## What is CVE-2026-40574?

CVE-2026-40574 is a medium-severity authentication bypass vulnerability in oauth2-proxy, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OAuth2 Proxy is a reverse proxy that provides authentication using OAuth2 providers. Prior to 7.15.2, an authorization bypass exists in OAuth2 Proxy as part of the email_domain enforcement option. An attacker may be able to authenticate with an email claim such as attacker@evil.com@company.com and satisfy an allowed domain check for company.com, even though the claim is not a valid email address. The issue ONLY affects deployments that rely on email_domain restrictions and accept email claim values from identity providers or claim mappings that do not strictly enforce normal email syntax. This vulnerability is fixed in 7.15.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-40574?

5 open source packages ship an affected version, including github.com/oauth2-proxy/oauth2-proxy/v7, oauth2-proxy and github.com/oauth2-proxy/oauth2-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.15.2 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.15.2 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.15.2 |
| `oauth2-proxy` | Bitnami | All versions | 7.15.2 |
| `github.com/oauth2-proxy/oauth2-proxy` | Go | All versions | None |

Products: Oauth2 Proxy Project Oauth2 Proxy.

## How do I fix CVE-2026-40574?

Upgrade github.com/oauth2-proxy/oauth2-proxy/v7 to 7.15.2 or later.

## Is CVE-2026-40574 being exploited?

There is no known exploitation of CVE-2026-40574 in the wild and no public exploit code.

## Other vulnerabilities in oauth2-proxy

- [CVE-2026-40575](https://insights.sbomify.com/CVE-2026-40575/): OAuth2 Proxy has an Authentication Bypass via X-Forwarded-Uri Header Spoofing (critical 9.1)
- [CVE-2026-34457](https://insights.sbomify.com/CVE-2026-34457/): OAuth2 Proxy: Health Check User-Agent Matching Bypasses Authentication in auth_request Mode (critical 9.1)
- [CVE-2025-54576](https://insights.sbomify.com/CVE-2025-54576/): OAuth2-Proxy has authentication bypass in oauth2-proxy skip_auth_routes due to Query Parameter inclusion (critical 9.1)
- [CVE-2017-1000069](https://insights.sbomify.com/CVE-2017-1000069/): Cross-site Request Forgery (CSRF) (high 8.8)
- [CVE-2026-41059](https://insights.sbomify.com/CVE-2026-41059/): OAuth2 Proxy has an Authentication Bypass via Fragment Confusion in skip_auth_routes and skip_auth_regex (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40574 and fix it if it is affected.

What it is: CVE-2026-40574 is a medium-severity authentication bypass vulnerability in oauth2-proxy, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40574 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.15.2
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.15.2
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.15.2
- oauth2-proxy (Bitnami): affected all versions; fixed in 7.15.2
- github.com/oauth2-proxy/oauth2-proxy (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40574/ (Markdown: https://insights.sbomify.com/CVE-2026-40574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40574
- OSV: https://osv.dev/vulnerability/CVE-2026-40574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40574/
Summaries are generated and may contain mistakes; the official description above is the record.
