# CVE-2026-40594: pyLoad: Session Cookie Security Downgrade via Untrusted X-Forwarded-Proto Header Spoofing (Global State Race Condition)

> Attackers can spoof headers to trigger a race condition that downgrades session cookie security or causes denial of service in pyLoad.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-mp82-fmj6-f22v, PYSEC-2026-125

## What is CVE-2026-40594?

CVE-2026-40594 is a medium-severity vulnerability in pyload, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyLoad is a free and open-source download manager written in Python. Prior to 0.5.0b3.dev98, the set_session_cookie_secure before_request handler in src/pyload/webui/app/__init__.py reads the X-Forwarded-Proto header from any HTTP request without validating that the request originates from a trusted proxy, then mutates the global Flask configuration SESSION_COOKIE_SECURE on every request. Because pyLoad uses the multi-threaded Cheroot WSGI server (request_queue_size=512), this creates a race condition where an attacker's request can influence the Secure flag on other users' session cookies — either downgrading cookie security behind a TLS proxy or causing a session denial-of-service on plain HTTP deployments. This vulnerability is fixed in 0.5.0b3.dev98.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-40594?

3 open source packages ship an affected version, including pyload-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev69 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev98 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev98 |

Products: Pyload-Ng Project Pyload-Ng.

## How do I fix CVE-2026-40594?

Upgrade pyload-ng to a fixed version for your release line: 0.5.0b3.dev69 or 0.5.0b3.dev98.

## Is CVE-2026-40594 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40594 exists.

## Other vulnerabilities in pyload

- [CVE-2025-54802](https://insights.sbomify.com/CVE-2025-54802/): pyLoad CNL Blueprint is vulnerable to Path Traversal through `dlc_path` leading to Remote Code Execution (RCE) (critical 9.8)
- [CVE-2024-22416](https://insights.sbomify.com/CVE-2024-22416/): Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation (critical 9.7)
- [CVE-2023-0488](https://insights.sbomify.com/CVE-2023-0488/): Cross-site Scripting (XSS) - Stored in pyload/pyload (critical 9.6)
- [CVE-2026-35459](https://insights.sbomify.com/CVE-2026-35459/): pyLoad has SSRF fix bypass via HTTP redirect (critical 9.3)
- [CVE-2026-35463](https://insights.sbomify.com/CVE-2026-35463/): pyLoad has Improper Neutralization of Special Elements used in an OS Command (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40594 and fix it if it is affected.

What it is: CVE-2026-40594 is a medium-severity vulnerability in pyload, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40594 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev69
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev98
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev98

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40594/ (Markdown: https://insights.sbomify.com/CVE-2026-40594/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40594
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40594
- OSV: https://osv.dev/vulnerability/CVE-2026-40594

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40594/
Summaries are generated and may contain mistakes; the official description above is the record.
