# CVE-2026-40596: MantisBT is vulnerable to XSS and potential account takeover via user font family preference update

> Authenticated users can inject HTML via font settings, leading to reflected XSS and potential account takeover in MantisBT.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:L/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 22 May 2026
- **Also known as:** GHSA-j3v9-553h-x28j

## What is CVE-2026-40596?

CVE-2026-40596 is a high-severity cross-site scripting vulnerability in mantisbt, published on 22 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.11.0 through 2.28.1 allow any authenticated user to inject arbitrary HTML by updating their account's font family. Upon exploitation, an XSS payload would be reflected on every MantisBT page. Leveraging another vulnerability (CSP bypass, see GHSA-9c3j-xm6v-j7j3), the attacker could achieve account takeover. This issue has been fixed in version 2.28.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-40596?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | From 2.11.0 | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | From 2.11.0 | 2.28.2 |

## How do I fix CVE-2026-40596?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-40596 being exploited?

There is no known exploitation of CVE-2026-40596 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40596 and fix it if it is affected.

What it is: CVE-2026-40596 is a high-severity cross-site scripting vulnerability in mantisbt, published on 22 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-40596 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected from 2.11.0; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected from 2.11.0; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40596/ (Markdown: https://insights.sbomify.com/CVE-2026-40596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40596
- OSV: https://osv.dev/vulnerability/CVE-2026-40596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40596/
Summaries are generated and may contain mistakes; the official description above is the record.
