# CVE-2026-40598: MantisBT has Potential Referer-Based Reflected HTML Injection / XSS in Tag Update Page

> Attackers can inject HTML via the Referer header in MantisBT, potentially leading to cross-site scripting under specific server configurations.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 23 May 2026
- **Also known as:** GHSA-6jh4-47v2-4g37

## What is CVE-2026-40598?

CVE-2026-40598 is a medium-severity cross-site scripting vulnerability in mantisbt, published on 22 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. In versions 2.28.1 and below, improper escaping of the redirection page (retrieved from the request's Referer header) allows an attacker to inject HTML. While this is generally not directly actionable as modern browsers will URL-encode special characters, on some specific server configurations this could poison the cache, leading to cross-site scripting. This issue has been fixed in version 2.28.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-40598?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.2 |

## How do I fix CVE-2026-40598?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-40598 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40598 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40598 and fix it if it is affected.

What it is: CVE-2026-40598 is a medium-severity cross-site scripting vulnerability in mantisbt, published on 22 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40598 exists.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40598/ (Markdown: https://insights.sbomify.com/CVE-2026-40598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40598
- OSV: https://osv.dev/vulnerability/CVE-2026-40598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40598/
Summaries are generated and may contain mistakes; the official description above is the record.
