# CVE-2026-40602: hass-cli: Handling of user-supplied Jinja2 templates


- **Severity:** Medium 5.6 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-33qf-q99x-wpm8, PYSEC-2026-2518

## What is CVE-2026-40602?

CVE-2026-40602 is a medium-severity vulnerability in home-assistant-ecosystem home-assistant-cli, published on 21 Apr 2026. 

### Official description

The Home Assistant Command-line interface (hass-cli) is a command-line tool for Home Assistant. Up to 1.0.0 of home-assitant-cli an unrestricted environment was used to handle Jninja2 templates instead of a sandboxed one. The user-supplied input within Jinja2 templates was rendered locally with no restrictions. This gave users access to Python's internals and extended the scope of templating beyond the intended usage. This vulnerability is fixed in 1.0.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-40602?

3 open source packages ship an affected version, including homeassistant-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `homeassistant-cli` | PyPI | All versions | 1.0.0 |
| `homeassistant-cli` | PyPI | All versions | 1.0.0 |
| `homeassistant-cli` | PyPI | All versions | 1.0.0 |

Products: Home-Assistant-Ecosystem Home Assistant Command-Line Interface.

## How do I fix CVE-2026-40602?

Upgrade homeassistant-cli to 1.0.0 or later.

## Is CVE-2026-40602 being exploited?

There is no known exploitation of CVE-2026-40602 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40602 and fix it if it is affected.

What it is: CVE-2026-40602 is a medium-severity vulnerability in home-assistant-ecosystem home-assistant-cli, published on 21 Apr 2026. 
Exploitation: There is no known exploitation of CVE-2026-40602 in the wild and no public exploit code.

Affected packages and fixed versions:
- homeassistant-cli (PyPI): affected all versions; fixed in 1.0.0
- homeassistant-cli (PyPI): affected all versions; fixed in 1.0.0
- homeassistant-cli (PyPI): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40602/ (Markdown: https://insights.sbomify.com/CVE-2026-40602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40602
- OSV: https://osv.dev/vulnerability/CVE-2026-40602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40602/
Summaries are generated and may contain mistakes; the official description above is the record.
