# CVE-2026-40607: MantisBT is Vulnerable to Stored XSS Through its Saved-Filter Owner Column

> Attackers can inject arbitrary HTML via saved filter owners in MantisBT, potentially leading to session hijacking or malicious script execution.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-f633-865q-2mhh

## What is CVE-2026-40607?

CVE-2026-40607 is a high-severity cross-site scripting vulnerability in mantisbt, published on 22 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. In versions 2.11.0 through 2.28.1, a Stored XSS vulnerability is caused by incorrect escaping of a saved filter's owner, allowing an attacker to inject arbitrary HTML on systems where $g_show_user_realname = ON. Note that By default, only users with Manager access level or above can save their filters publicly. This issue has been fixed in version 2.28.2. If developers are unable to update immediately, they can work around this issue by preventing display of users' real names (set $g_ show_user_realname = OFF; in configuration), and restricting the ability to store filters (set $g_stored_query_create_threshold / $g_stored_query_create_shared_threshold to NOBODY).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-40607?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | From 2.1.0 | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | From 2.1.0 | 2.28.2 |

## How do I fix CVE-2026-40607?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-40607 being exploited?

There is no known exploitation of CVE-2026-40607 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40607 and fix it if it is affected.

What it is: CVE-2026-40607 is a high-severity cross-site scripting vulnerability in mantisbt, published on 22 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40607 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected from 2.1.0; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected from 2.1.0; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40607/ (Markdown: https://insights.sbomify.com/CVE-2026-40607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40607
- OSV: https://osv.dev/vulnerability/CVE-2026-40607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40607/
Summaries are generated and may contain mistakes; the official description above is the record.
