# CVE-2026-40610: BentoML has Information Disclosure in `bentoml build` via symlink traversal in the build context

> Attackers can exfiltrate sensitive local files from the build host into Bento artifacts via symlink traversal during the build process.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-mcfx-4vc6-qgxv, PYSEC-2026-2399

## What is CVE-2026-40610?

CVE-2026-40610 is a medium-severity path traversal vulnerability in BentoML, published on 22 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

BentoML is a Python library for building online serving systems optimized for AI apps and model inference. In versions 1.4.38 and prior, the build packaging workflow follows attacker-controlled symlinks inside the build context and copies the referenced file contents into the generated Bento artifact. If a victim builds an untrusted repository or other attacker-supplied build context, the attacker can place a symlink such as loot.txt -> /tmp/outside-marker.txt or a link to a more sensitive local file. When bentoml build runs, BentoML dereferences the symlink and packages the target file contents into the Bento. The leaked file can then propagate further through export, push, or containerization workflows. An attacker can exfiltrate local files from the build host into the Bento artifact, exposing secrets such as cloud credentials, SSH keys, API tokens, environment files, or other sensitive local configurations. Because Bento artifacts are commonly exported, uploaded, stored, or containerized after build, the leaked file contents can spread beyond the original build machine. This issue has been fixed in version 1.4.39.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-40610?

3 open source packages ship an affected version, including bentoml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bentoml` | PyPI | All versions | 1.4.39 |
| `bentoml` | PyPI | All versions | 1.4.39 |
| `bentoml` | PyPI | All versions | 1.4.39 |

Products: Bentoml Bentoml.

## How do I fix CVE-2026-40610?

Upgrade bentoml to 1.4.39 or later.

## Is CVE-2026-40610 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40610 exists.

## Other vulnerabilities in BentoML

- [CVE-2025-54381](https://insights.sbomify.com/CVE-2025-54381/): BentoML is Vulnerable to an SSRF Attack Through File Upload Processing (critical 9.9)
- [CVE-2025-32375](https://insights.sbomify.com/CVE-2025-32375/): Insecure Deserialization leads to RCE in BentoML's runner server (critical 9.8)
- [CVE-2025-27520](https://insights.sbomify.com/CVE-2025-27520/): BentoML Allows Remote Code Execution (RCE) via Insecure Deserialization (critical 9.8)
- [CVE-2026-44345](https://insights.sbomify.com/CVE-2026-44345/): BentoML: Dockerfile command injection via docker.base_image (high 8.8)
- [CVE-2026-44346](https://insights.sbomify.com/CVE-2026-44346/): BentoML: Dockerfile command injection via envs[*].name in bentofile.yaml (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40610 and fix it if it is affected.

What it is: CVE-2026-40610 is a medium-severity path traversal vulnerability in BentoML, published on 22 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40610 exists.

Affected packages and fixed versions:
- bentoml (PyPI): affected all versions; fixed in 1.4.39
- bentoml (PyPI): affected all versions; fixed in 1.4.39
- bentoml (PyPI): affected all versions; fixed in 1.4.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40610/ (Markdown: https://insights.sbomify.com/CVE-2026-40610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40610
- OSV: https://osv.dev/vulnerability/CVE-2026-40610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40610/
Summaries are generated and may contain mistakes; the official description above is the record.
