CVE-2026-40682 Apache OpenNLP: XXE via Dictionary Parsing in DictionaryEntryPersistor

Critical 9.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-40682?

CVE-2026-40682 is a critical vulnerability in Apache OpenNLP, published on 4 May 2026.

Official description

XML External Entity (XXE) via Unsanitized Dictionary Parsing in Apache OpenNLP DictionaryEntryPersistor

Versions Affected: before 2.5.9, before 3.0.0-M3

Description: The DictionaryEntryPersistor class initializes a static SAXParserFactory at class-load time without enabling FEATURE_SECURE_PROCESSING or disabling DTD processing. When create(InputStream, EntryInserter) is invoked, the only feature set on the XMLReader is namespace support — external entity resolution and DOCTYPE declarations remain fully enabled. An attacker who can supply a crafted dictionary file (e.g., a stop-word list or domain dictionary) containing a malicious DOCTYPE declaration can trigger local file disclosure via file:// entity references or server-side request forgery via http:// entity references during SAX parsing, before the application processes a single dictionary entry. This is inconsistent with the project's own XmlUtil.createSaxParser() helper, which correctly sets FEATURE_SECURE_PROCESSING and disallow-doctype-decl and is used by all other XML parsing paths in the codebase. The public Dictionary(InputStream) constructor delegates directly to this method and is the documented API for loading user-supplied dictionaries, making untrusted input a realistic scenario.

Mitigation: 2.x users should upgrade to 2.5.9. 3.x users should upgrade to 3.0.0-M3. Users who cannot upgrade immediately should ensure that all dictionary files are sourced from trusted origins and should consider wrapping the Dictionary(InputStream) constructor with input validation that rejects any XML containing a DOCTYPE declaration before it reaches the parser.

Weakness: CWE-611

Which versions are affected by CVE-2026-40682?

6 open source packages ship an affected version, including org.apache.opennlp:opennlp-tools. It affects 1 product.

PackageAffectedFixed in
org.apache.opennlp:opennlp-tools MavenAll versions1.9.5
org.apache.opennlp:opennlp-tools MavenAll versions1.9.5
org.apache.opennlp:opennlp-tools MavenFrom 2.0.02.5.9
org.apache.opennlp:opennlp-tools MavenFrom 2.0.02.5.9
org.apache.opennlp:opennlp-tools MavenFrom 3.0.0-M13.0.0-M3
org.apache.opennlp:opennlp-tools MavenFrom 3.0.0-M13.0.0-M3

Products include Apache Opennlp.

How do I fix CVE-2026-40682?

Upgrade org.apache.opennlp:opennlp-tools to a fixed version for your release line: 1.9.5, 2.5.9 or 3.0.0-M3.

Is CVE-2026-40682 being exploited?

There is no known exploitation of CVE-2026-40682 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-40682, GHSA-4v8g-86x5-3vrc, UBUNTU-CVE-2026-40682.

Is CVE-2026-40682 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free