# CVE-2026-40682: Apache OpenNLP: XXE via Dictionary Parsing in DictionaryEntryPersistor


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 2 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-40682, GHSA-4v8g-86x5-3vrc, UBUNTU-CVE-2026-40682

## What is CVE-2026-40682?

CVE-2026-40682 is a critical vulnerability in Apache OpenNLP, published on 4 May 2026. 

### Official description

XML External Entity (XXE) via Unsanitized Dictionary Parsing in Apache OpenNLP DictionaryEntryPersistor

Versions Affected: before 2.5.9, before 3.0.0-M3

Description: The DictionaryEntryPersistor class initializes a static SAXParserFactory at class-load time without enabling FEATURE_SECURE_PROCESSING or disabling DTD processing. When create(InputStream, EntryInserter) is invoked, the only feature set on the XMLReader is namespace support — external entity resolution and DOCTYPE declarations remain fully enabled. An attacker who can supply a crafted dictionary file (e.g., a stop-word list or domain dictionary) containing a malicious DOCTYPE declaration can trigger local file disclosure via file:// entity references or server-side request forgery via http:// entity references during SAX parsing, before the application processes a single dictionary entry. This is inconsistent with the project's own XmlUtil.createSaxParser() helper, which correctly sets FEATURE_SECURE_PROCESSING and disallow-doctype-decl and is used by all other XML parsing paths in the codebase. The public Dictionary(InputStream) constructor delegates directly to this method and is the documented API for loading user-supplied dictionaries, making untrusted input a realistic scenario.

Mitigation: 2.x users should upgrade to 2.5.9. 3.x users should upgrade to 3.0.0-M3. Users who cannot upgrade immediately should ensure that all dictionary files are sourced from trusted origins and should consider wrapping the Dictionary(InputStream) constructor with input validation that rejects any XML containing a DOCTYPE declaration before it reaches the parser.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-40682?

6 open source packages ship an affected version, including org.apache.opennlp:opennlp-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.opennlp:opennlp-tools` | Maven | All versions | 1.9.5 |
| `org.apache.opennlp:opennlp-tools` | Maven | All versions | 1.9.5 |
| `org.apache.opennlp:opennlp-tools` | Maven | From 2.0.0 | 2.5.9 |
| `org.apache.opennlp:opennlp-tools` | Maven | From 2.0.0 | 2.5.9 |
| `org.apache.opennlp:opennlp-tools` | Maven | From 3.0.0-M1 | 3.0.0-M3 |
| `org.apache.opennlp:opennlp-tools` | Maven | From 3.0.0-M1 | 3.0.0-M3 |

Products: Apache Opennlp.

## How do I fix CVE-2026-40682?

Upgrade org.apache.opennlp:opennlp-tools to a fixed version for your release line: 1.9.5, 2.5.9 or 3.0.0-M3.

## Is CVE-2026-40682 being exploited?

There is no known exploitation of CVE-2026-40682 in the wild and no public exploit code.

## Other vulnerabilities in Apache OpenNLP

- [CVE-2026-82617](https://insights.sbomify.com/CVE-2026-82617/): Apache OpenNLP, Apache OpenNLP: ReDoS / stack exhaustion in RegexNameFinderFactory built-in EMAIL and URL patterns (critical 10.0)
- [CVE-2026-42027](https://insights.sbomify.com/CVE-2026-42027/): Apache OpenNLP: Arbitrary Class Instantiation via Model Manifest in ExtensionLoader (critical 9.8)
- [CVE-2017-12620](https://insights.sbomify.com/CVE-2017-12620/): Improper Restriction of XML External Entity Reference in Apache OpenNLP (critical 9.8)
- [CVE-2026-67211](https://insights.sbomify.com/CVE-2026-67211/): Apache OpenNLP: OOM DoS via Unbounded Array Allocation in SymSpellModelSerializer (high 7.5)
- [CVE-2026-42440](https://insights.sbomify.com/CVE-2026-42440/): Apache OpenNLP: OOM DoS via Unbounded Array Allocation in AbstractModelReader (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40682 and fix it if it is affected.

What it is: CVE-2026-40682 is a critical vulnerability in Apache OpenNLP, published on 4 May 2026. 
Exploitation: There is no known exploitation of CVE-2026-40682 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.opennlp:opennlp-tools (Maven): affected all versions; fixed in 1.9.5
- org.apache.opennlp:opennlp-tools (Maven): affected all versions; fixed in 1.9.5
- org.apache.opennlp:opennlp-tools (Maven): affected from 2.0.0; fixed in 2.5.9
- org.apache.opennlp:opennlp-tools (Maven): affected from 2.0.0; fixed in 2.5.9
- org.apache.opennlp:opennlp-tools (Maven): affected from 3.0.0-M1; fixed in 3.0.0-M3
- org.apache.opennlp:opennlp-tools (Maven): affected from 3.0.0-M1; fixed in 3.0.0-M3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40682/ (Markdown: https://insights.sbomify.com/CVE-2026-40682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40682
- OSV: https://osv.dev/vulnerability/CVE-2026-40682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40682/
Summaries are generated and may contain mistakes; the official description above is the record.
