# CVE-2026-40683: OpenStack Keystone: LDAP identity backend does not convert enabled attribute to boolean

> Disabled LDAP users can authenticate and perform actions in OpenStack Keystone due to incorrect boolean conversion of the enabled attribute.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 5 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-40683, GHSA-pfx2-9x9m-7ghx, PYSEC-2026-2550

## What is CVE-2026-40683?

CVE-2026-40683 is a high-severity authentication bypass vulnerability in OpenStack Keystone, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In OpenStack Keystone before 28.0.1, the LDAP identity backend does not convert the user enabled attribute to a boolean when the user_enabled_invert configuration option is False (the default). The _ldap_res_to_model method in the UserApi class only performed string-to-boolean conversion when user_enabled_invert was True. When False, the raw string value from LDAP (e.g., "FALSE") was used directly. Since non-empty strings are truthy in Python, users marked as disabled in LDAP were treated as enabled by Keystone, allowing them to authenticate and perform actions. All deployments using the LDAP identity backend without user_enabled_invert=True or user_enabled_emulation are affected.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2026-40683?

3 open source packages ship an affected version, including keystone.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 28.0.1 |
| `keystone` | PyPI | All versions | 28.0.1 |
| `keystone` | PyPI | All versions | 28.0.1 |

## How do I fix CVE-2026-40683?

Upgrade keystone to 28.0.1 or later.

## Is CVE-2026-40683 being exploited?

There is no known exploitation of CVE-2026-40683 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40683 and fix it if it is affected.

What it is: CVE-2026-40683 is a high-severity authentication bypass vulnerability in OpenStack Keystone, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40683 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 28.0.1
- keystone (PyPI): affected all versions; fixed in 28.0.1
- keystone (PyPI): affected all versions; fixed in 28.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40683/ (Markdown: https://insights.sbomify.com/CVE-2026-40683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40683
- OSV: https://osv.dev/vulnerability/CVE-2026-40683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40683/
Summaries are generated and may contain mistakes; the official description above is the record.
