{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 7 products.","exploited":"There is no known exploitation of CVE-2026-40701 in the wild and no public exploit code.","fix":"Upgrade nginx to 1.30.1 or later.","what":"CVE-2026-40701 is a medium-severity use after free vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40701 and fix it if it is affected.\n\nWhat it is: CVE-2026-40701 is a medium-severity use after free vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40701 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 1.19.0; fixed in 1.30.1\n- nginx-gateway (Bitnami): affected from 1.19.0; fixed in 1.30.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40701/ (Markdown: https://insights.sbomify.com/CVE-2026-40701/index.md)","id":"CVE-2026-40701","markdown":"https://insights.sbomify.com/CVE-2026-40701/index.md","name":"CVE-2026-40701","record":{"aliases":["ALPINE-CVE-2026-40701","AZL-86850","BELL-CVE-2026-40701","BIT-nginx-2026-40701","BIT-nginx-gateway-2026-40701","DEBIAN-CVE-2026-40701","ECHO-cbfe-5521-46aa","GHSA-x88q-x2r7-vg3g","MINI-46qf-f9vw-4m46","MINI-c3w3-2qj4-8v23","MINI-qhm3-fr99-hfmw","MINI-v453-p2c9-mfcp","MINI-x6rw-q733-vwfh","UBUNTU-CVE-2026-40701"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX web server","requires_auth":"none","summary":"An unauthenticated attacker can trigger a heap-use-after-free in NGINX when specific SSL verification and OCSP settings are enabled, causing data modification or service restart.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"dos","vendor":"f5"},{"product":"nginx_gateway_fabric","vendor":"f5"},{"product":"nginx_ingress_controller","vendor":"f5"},{"product":"nginx_instance_manager","vendor":"f5"},{"product":"nginx_open_source","vendor":"f5"},{"product":"nginx_plus","vendor":"f5"},{"product":"waf","vendor":"f5"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssl_module module when the ssl_verify_client directive is set to \"on\" or \"optional,\" and the ssl_ocsp directive is set to \"on\" or the leaf parameters are configured with a resolver. With this configuration, an unauthenticated attacker can send requests along with conditions beyond its control that may cause a heap-use-after-free error in the NGINX worker process. This vulnerability may result in limited modification of data or the NGINX worker process restarting.\n\n Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-05-28","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-28T18:49:27Z","kind":"github_poc","ref":"https://github.com/edgecases-PurpleHax/cve-images","stars":1,"title":"Intentionally-vulnerable nginx 1.30.0 CVE lab images (CVE-2026-40701/42934/42945/42946) for isolated security research. Lab use only."}],"tier":"poc_unverified"},"has_fix":true,"headline":"NGINX ngx_http_ssl_module vulnerability","id":"CVE-2026-40701","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"use_after_free","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"EVoke Systems EVoke CSMS Missing Authentication for Critical Function","id":"CVE-2026-40702"},"packages":[{"ecosystem":"Bitnami","fixed":["1.30.1"],"introduced":["1.19.0"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2026-40701"},{"ecosystem":"Bitnami","fixed":["1.30.1"],"introduced":["1.19.0"],"last_affected":[],"package":"nginx-gateway","purl":"pkg:bitnami/nginx-gateway","source":"BIT-nginx-gateway-2026-40701"}],"prev":{"headline":"BIG-IP Configuration utility vulnerability","id":"CVE-2026-40699"},"products":["NGINX Open Source","NGINX Plus"],"published":"2026-05-13","related":[{"cvss_score":9.2,"headline":"NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability","id":"CVE-2026-42055","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":9.2,"headline":"NGINX ngx_http_rewrite_module vulnerability","id":"CVE-2026-42945","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":8.3,"headline":"NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerability","id":"CVE-2026-42946","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":6.9,"headline":"NGINX ngx_quic_module vulnerability","id":"CVE-2026-40460","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":6.3,"headline":"NGINX ngx_http_charset_module vulnerability","id":"CVE-2026-48142","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":6.3,"headline":"NGINX ngx_http_charset_module vulnerability","id":"CVE-2026-42934","kev_date_added":null,"published":"2026-05-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["F5"]},"summary":"An unauthenticated attacker can trigger a heap-use-after-free in NGINX when specific SSL verification and OCSP settings are enabled, causing data modification or service restart.","url":"https://insights.sbomify.com/CVE-2026-40701/"}