CVE-2026-40860 Apache Camel: Unsafe Deserialization of JMS ObjectMessage in camel-jms, camel-sjms, camel-sjms2 and camel-amqp

Critical 9.8 Published Updated

An attacker can achieve remote code execution by publishing a crafted JMS ObjectMessage to a queue consumed by an Apache Camel application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40860?

CVE-2026-40860 is a critical unsafe deserialization vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

JmsBinding.extractBodyFromJms() in camel-jms, and the equivalent JmsBinding class in camel-sjms, deserialized the payload of incoming JMS ObjectMessage values via javax.jms.ObjectMessage.getObject() without applying any ObjectInputFilter, class allowlist or class denylist. Because this code path is reached whenever the mapJmsMessage option is enabled (the default) and Camel acts as a JMS consumer, an attacker able to publish a crafted ObjectMessage to a queue or topic consumed by a Camel application could achieve remote code execution when a deserialization gadget chain was present on the classpath. The same handling was reached transitively through camel-sjms2 (whose Sjms2Endpoint extends SjmsEndpoint) and through camel-amqp (whose AMQPJmsBinding extends JmsBinding), and by other JMS-family components built on JmsComponent such as camel-activemq and camel-activemq6.

This issue affects Apache Camel: from 3.0.0 before 4.14.7, from 4.15.0 before 4.18.2, from 4.19.0 before 4.20.0.

Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.7. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.2.

Weakness: CWE-502

Which versions are affected by CVE-2026-40860?

36 open source packages ship an affected version, including org.apache.camel:camel-activemq, org.apache.camel:camel-activemq6 and org.apache.camel:camel-amqp. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-activemq MavenFrom 3.0.04.14.7
org.apache.camel:camel-activemq MavenFrom 3.0.04.14.7
org.apache.camel:camel-activemq MavenFrom 4.15.04.18.2
org.apache.camel:camel-activemq MavenFrom 4.15.04.18.2
org.apache.camel:camel-activemq MavenFrom 4.19.04.20.0
org.apache.camel:camel-activemq MavenFrom 4.19.04.20.0
30 more packages
org.apache.camel:camel-activemq6 MavenFrom 3.0.04.14.7
org.apache.camel:camel-activemq6 MavenFrom 3.0.04.14.7
org.apache.camel:camel-activemq6 MavenFrom 4.15.04.18.2
org.apache.camel:camel-activemq6 MavenFrom 4.15.04.18.2
org.apache.camel:camel-activemq6 MavenFrom 4.19.04.20.0
org.apache.camel:camel-activemq6 MavenFrom 4.19.04.20.0
org.apache.camel:camel-amqp MavenFrom 3.0.04.14.7
org.apache.camel:camel-amqp MavenFrom 3.0.04.14.7
org.apache.camel:camel-amqp MavenFrom 4.15.04.18.2
org.apache.camel:camel-amqp MavenFrom 4.15.04.18.2
org.apache.camel:camel-amqp MavenFrom 4.19.04.20.0
org.apache.camel:camel-amqp MavenFrom 4.19.04.20.0
org.apache.camel:camel-jms MavenFrom 3.0.04.14.7
org.apache.camel:camel-jms MavenFrom 3.0.04.14.7
org.apache.camel:camel-jms MavenFrom 4.15.04.18.2
org.apache.camel:camel-jms MavenFrom 4.15.04.18.2
org.apache.camel:camel-jms MavenFrom 4.19.04.20.0
org.apache.camel:camel-jms MavenFrom 4.19.04.20.0
org.apache.camel:camel-sjms MavenFrom 3.0.04.14.7
org.apache.camel:camel-sjms MavenFrom 3.0.04.14.7
org.apache.camel:camel-sjms MavenFrom 4.15.04.18.2
org.apache.camel:camel-sjms MavenFrom 4.15.04.18.2
org.apache.camel:camel-sjms MavenFrom 4.19.04.20.0
org.apache.camel:camel-sjms MavenFrom 4.19.04.20.0
org.apache.camel:camel-sjms2 MavenFrom 3.0.04.14.7
org.apache.camel:camel-sjms2 MavenFrom 3.0.04.14.7
org.apache.camel:camel-sjms2 MavenFrom 4.15.04.18.2
org.apache.camel:camel-sjms2 MavenFrom 4.15.04.18.2
org.apache.camel:camel-sjms2 MavenFrom 4.19.04.20.0
org.apache.camel:camel-sjms2 MavenFrom 4.19.04.20.0

Products include Apache Camel.

How do I fix CVE-2026-40860?

Upgrade org.apache.camel:camel-activemq to a fixed version for your release line: 4.14.7, 4.18.2 or 4.20.0.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-40860 being exploited?

There is no known exploitation of CVE-2026-40860 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-m5vh-3fw5-5wgh, MINI-c4j9-24m4-gpj3, MINI-pgqq-rfwm-3855, MINI-vh7x-fxmv-8w4x, MINI-xvq4-w8cq-7gc7.

Is CVE-2026-40860 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free