CVE-2026-40863 PhpSpreadsheet: CPU Denial of Service via Unbounded Row Index in SpreadsheetML XML Reader
Attackers can cause CPU exhaustion and denial of service by crafting malicious SpreadsheetML XML files with unbounded row indices in PhpSpreadsheet.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-40863?
CVE-2026-40863 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the SpreadsheetML XML reader (Reader\Xml) does not validate the ss:Index row attribute against the maximum allowed row count (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a SpreadsheetML XML file with ss:Index="999999999" on a <Row> element, which inflates the internal cachedHighestRow to ~1 billion. Any subsequent call to getRowIterator() without an explicit end row will attempt to iterate ~1 billion rows, causing CPU exhaustion and denial of service. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.
Weakness: CWE-770
Which versions are affected by CVE-2026-40863?
10 open source packages ship an affected version, including phpoffice/phpspreadsheet. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpoffice/phpspreadsheet Packagist | All versions | 1.30.6 |
phpoffice/phpspreadsheet Packagist | All versions | 1.30.6 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.16 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.16 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.5 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.5 |
4 more packages
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.5 |
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.5 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.7.0 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.7.0 |
Products include Phpoffice Phpspreadsheet.
How do I fix CVE-2026-40863?
Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.6, 2.1.16, 2.4.5 or 3.10.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-40863 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40863 exists.
Other vulnerabilities in PHPOffice PhpSpreadsheet
- CVE-2026-34084 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load
- CVE-2024-45048 XML External Entity Reference (XXE) in PHPSpreadsheet
- CVE-2019-12331 XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue
- CVE-2018-19277 XXE in PHPSpreadsheet due to encoding issue
- CVE-2024-56365 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class
Sources
Also known as GHSA-84wq-86v6-x5j6.