# CVE-2026-40868: kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token

> Attackers can leak Kyverno service account tokens to external endpoints via policy-controlled API calls, enabling unauthorized access to cluster resources.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** BIT-kyverno-2026-40868, ECHO-a7ef-0b97-6536, GHSA-q93q-v844-jrqp, GO-2026-5575, MINI-2p4q-qpv3-v7f4, MINI-6gh8-p2rc-3wxq, MINI-739j-gp4v-qjx6, MINI-73h3-hvqm-x396, MINI-92hf-6g2f-pm64, MINI-c25w-m2x5-98hv, MINI-fhq4-rpw6-7xgr, MINI-fr29-5gmv-wrpq, MINI-ghmq-rv63-vj6h, MINI-pxj5-vw53-ph3f, MINI-qvpw-g27m-p78v, MINI-qwq4-9f8j-8j3f, MINI-vv5x-c496-x2wx

## What is CVE-2026-40868?

CVE-2026-40868 is a high-severity vulnerability in kyverno, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to 1.16.4, kyverno’s apiCall servicecall helper implicitly injects Authorization: Bearer ... using the kyverno controller serviceaccount token when a policy does not explicitly set an Authorization header. Because context.apiCall.service.url is policy-controlled, this can send the kyverno serviceaccount token to an attacker-controlled endpoint (confused deputy). Namespaced policies are blocked from servicecall usage by the namespaced urlPath gate in pkg/engine/apicall/apiCall.go, so this report is scoped to ClusterPolicy and global context usage. This vulnerability is fixed in 1.16.4.

Weakness: CWE-922 (Insecure Storage of Sensitive Information)

## Which versions are affected by CVE-2026-40868?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.17.0 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.17.0 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.17.0 |
| `kyverno` | Bitnami | All versions | 1.16.4 |

Products: Kyverno Kyverno.

## How do I fix CVE-2026-40868?

Upgrade github.com/kyverno/kyverno to 1.17.0 or later.

## Is CVE-2026-40868 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40868 exists.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2022-47633](https://insights.sbomify.com/CVE-2022-47633/): kyverno verifyImages rule bypass possible with malicious proxy/registry (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40868 and fix it if it is affected.

What it is: CVE-2026-40868 is a high-severity vulnerability in kyverno, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40868 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.17.0
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.17.0
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.17.0
- kyverno (Bitnami): affected all versions; fixed in 1.16.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40868/ (Markdown: https://insights.sbomify.com/CVE-2026-40868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40868
- OSV: https://osv.dev/vulnerability/CVE-2026-40868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40868/
Summaries are generated and may contain mistakes; the official description above is the record.
