{"answers":{"affected":"4 open source packages ship an affected version, including decidim-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-40869 in the wild and no public exploit code.","fix":"Upgrade decidim-core to a fixed version for your release line: 0.30.5 or 0.31.1.","what":"CVE-2026-40869 is a high-severity missing authorization vulnerability in decidim, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40869 and fix it if it is affected.\n\nWhat it is: CVE-2026-40869 is a high-severity missing authorization vulnerability in decidim, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40869 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim-core (RubyGems): affected from 0.19.0; fixed in 0.30.5\n- decidim-core (RubyGems): affected from 0.19.0; fixed in 0.30.5\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40869/ (Markdown: https://insights.sbomify.com/CVE-2026-40869/index.md)","id":"CVE-2026-40869","markdown":"https://insights.sbomify.com/CVE-2026-40869/index.md","name":"CVE-2026-40869","record":{"aliases":["GHSA-w5xj-99cg-rccm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Decidim participatory democracy","requires_auth":"none","summary":"Authenticated users can accept or reject any amendments, potentially gaining co-authorship privileges on proposals in Decidim.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"Decidim is a participatory democracy framework. Starting in version 0.19.0 and prior to versions 0.30.5 and 0.31.1, a vulnerability allows any registered and authenticated user to accept or reject any amendments. The impact is on any users who have created proposals where the amendments feature is enabled. This also elevates the user accepting the amendment as the author of the original proposal as people amending proposals are provided coauthorship on the coauthorable resources. Versions 0.30.5 and 0.31.1 fix the issue. As a workaround, disable amendment reactions for the amendable component (e.g. proposals).","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Decidim's comments API allows access to all commentable resources","id":"CVE-2026-40870"},"packages":[{"ecosystem":"RubyGems","fixed":["0.30.5"],"introduced":["0.19.0"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-w5xj-99cg-rccm"},{"ecosystem":"RubyGems","fixed":["0.30.5"],"introduced":["0.19.0"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-w5xj-99cg-rccm"},{"ecosystem":"RubyGems","fixed":["0.31.1"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-w5xj-99cg-rccm"},{"ecosystem":"RubyGems","fixed":["0.31.1"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-w5xj-99cg-rccm"}],"prev":{"headline":"kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token","id":"CVE-2026-40868"},"products":["decidim"],"published":"2026-04-21","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-21","vendors":["decidim"]},"summary":"Authenticated users can accept or reject any amendments, potentially gaining co-authorship privileges on proposals in Decidim.","url":"https://insights.sbomify.com/CVE-2026-40869/"}