# CVE-2026-40869: Decidim amendments can be accepted or rejected by anyone

> Authenticated users can accept or reject any amendments, potentially gaining co-authorship privileges on proposals in Decidim.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-w5xj-99cg-rccm

## What is CVE-2026-40869?

CVE-2026-40869 is a high-severity missing authorization vulnerability in decidim, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Decidim is a participatory democracy framework. Starting in version 0.19.0 and prior to versions 0.30.5 and 0.31.1, a vulnerability allows any registered and authenticated user to accept or reject any amendments. The impact is on any users who have created proposals where the amendments feature is enabled. This also elevates the user accepting the amendment as the author of the original proposal as people amending proposals are provided coauthorship on the coauthorable resources. Versions 0.30.5 and 0.31.1 fix the issue. As a workaround, disable amendment reactions for the amendable component (e.g. proposals).

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-40869?

4 open source packages ship an affected version, including decidim-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-core` | RubyGems | From 0.19.0 | 0.30.5 |
| `decidim-core` | RubyGems | From 0.19.0 | 0.30.5 |
| `decidim-core` | RubyGems | From 0.31.0.rc1 | 0.31.1 |
| `decidim-core` | RubyGems | From 0.31.0.rc1 | 0.31.1 |

Products: Decidim Decidim.

## How do I fix CVE-2026-40869?

Upgrade decidim-core to a fixed version for your release line: 0.30.5 or 0.31.1.

## Is CVE-2026-40869 being exploited?

There is no known exploitation of CVE-2026-40869 in the wild and no public exploit code.

## Other vulnerabilities in decidim

- [CVE-2026-23891](https://insights.sbomify.com/CVE-2026-23891/): Decidim has a Cross-site scripting (XSS) vulnerability via user name field (critical 9.3)
- [CVE-2023-36465](https://insights.sbomify.com/CVE-2023-36465/): Decidim has broken access control in templates (critical 9.1)
- [CVE-2025-65017](https://insights.sbomify.com/CVE-2025-65017/): Decidim's private data exports can lead to data leaks (high 8.2)
- [CVE-2023-32693](https://insights.sbomify.com/CVE-2023-32693/): Decidim Cross-site Scripting vulnerability in the external link redirections (high 8.1)
- [CVE-2023-34089](https://insights.sbomify.com/CVE-2023-34089/): Decidim Cross-site Scripting vulnerability in the processes filter (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40869 and fix it if it is affected.

What it is: CVE-2026-40869 is a high-severity missing authorization vulnerability in decidim, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40869 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim-core (RubyGems): affected from 0.19.0; fixed in 0.30.5
- decidim-core (RubyGems): affected from 0.19.0; fixed in 0.30.5
- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1
- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40869/ (Markdown: https://insights.sbomify.com/CVE-2026-40869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40869
- OSV: https://osv.dev/vulnerability/CVE-2026-40869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40869/
Summaries are generated and may contain mistakes; the official description above is the record.
