# CVE-2026-40882: OpenRemote has XXE in Velbus Asset Import

> An authenticated user can exploit XML External Entity processing in the Velbus asset import to disclose server-side files and perform SSRF.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-g24f-mgc3-jwwc

## What is CVE-2026-40882?

CVE-2026-40882 is a high-severity vulnerability in openremote, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenRemote is an open-source internet-of-things platform. Prior to version 1.22.0, the Velbus asset import path parses attacker-controlled XML without explicit XXE hardening. An authenticated user who can call the import endpoint may trigger XML external entity processing, which can lead to server-side file disclosure and SSRF. The target file must be less than 1023 characters. Version 1.22.0 fixes the issue.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-40882?

2 open source packages ship an affected version, including io.openremote:openremote-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.openremote:openremote-manager` | Maven | All versions | 1.22.0 |
| `io.openremote:openremote-manager` | Maven | All versions | 1.22.0 |

Products: Openremote Openremote.

## How do I fix CVE-2026-40882?

Upgrade io.openremote:openremote-manager to 1.22.0 or later.

## Is CVE-2026-40882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40882 exists.

## Other vulnerabilities in openremote

- [CVE-2026-39842](https://insights.sbomify.com/CVE-2026-39842/): OpenRemote is Vulnerable to Expression Injection (critical 10.0)
- [CVE-2022-31860](https://insights.sbomify.com/CVE-2022-31860/): Code injection in n/a (critical 9.8)
- [CVE-2026-62238](https://insights.sbomify.com/CVE-2026-62238/): OpenRemote < 1.26.0 SQL Injection via Crosstab Export (high 7.2)
- [CVE-2026-41166](https://insights.sbomify.com/CVE-2026-41166/): OpenRemote has Improper Access Control via updateUserRealmRoles function (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40882 and fix it if it is affected.

What it is: CVE-2026-40882 is a high-severity vulnerability in openremote, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40882 exists.

Affected packages and fixed versions:
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.22.0
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40882/ (Markdown: https://insights.sbomify.com/CVE-2026-40882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40882
- OSV: https://osv.dev/vulnerability/CVE-2026-40882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40882/
Summaries are generated and may contain mistakes; the official description above is the record.
