# CVE-2026-40894: OpenTelemetry dotnet: Excessive memory allocation when parsing OpenTelemetry propagation headers

> Attackers can cause denial of service in applications using OpenTelemetry dotnet libraries by sending crafted propagation headers that trigger excessive memory allocation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-g94r-2vxg-569j, MINI-cmrr-7m33-j4jp, ROOT-APP-NUGET-CVE-2026-40894

## What is CVE-2026-40894?

CVE-2026-40894 is a medium-severity denial of service vulnerability in open-telemetry OpenTelemetry.Api, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenTelemetry dotnet is a dotnet telemetry framework. In OpenTelemetry.Api 0.5.0-beta.2 to 1.15.2 and OpenTelemetry.Extensions.Propagators 1.3.1 to 1.15.2, The implementation details of the baggage, B3 and Jaeger processing code in the OpenTelemetry.Api and OpenTelemetry.Extensions.Propagators NuGet packages can allocate excessive memory when parsing which could create a potential denial of service (DoS) in the consuming application. This vulnerability is fixed in 1.15.3.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-40894?

4 open source packages ship an affected version, including OpenTelemetry.Api and OpenTelemetry.Extensions.Propagators. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OpenTelemetry.Api` | NuGet | From 0.5.0-beta.2 | 1.15.3 |
| `OpenTelemetry.Api` | NuGet | From 0.5.0-beta.2 | 1.15.3 |
| `OpenTelemetry.Extensions.Propagators` | NuGet | From 1.3.1 | 1.15.3 |
| `OpenTelemetry.Extensions.Propagators` | NuGet | From 1.3.1 | 1.15.3 |

Products: Opentelemetry Opentelemetry, Opentelemetry Opentelemetry.api, Opentelemetry Opentelemetry.extensions.propagators.

## How do I fix CVE-2026-40894?

Upgrade OpenTelemetry.Api to 1.15.3 or later.

## Is CVE-2026-40894 being exploited?

There is no known exploitation of CVE-2026-40894 in the wild and no public exploit code.

## Other vulnerabilities in open-telemetry OpenTelemetry.Api

- [CVE-2026-29181](https://insights.sbomify.com/CVE-2026-29181/): OpenTelemetry-Go multi-value `baggage` header extraction causes excessive allocations (remote dos amplification) (high 7.5)
- [CVE-2023-47108](https://insights.sbomify.com/CVE-2023-47108/): DoS vulnerability in otelgrpc (uncontrolled resource consumption) due to unbound cardinality metrics (high 7.5)
- [CVE-2023-45142](https://insights.sbomify.com/CVE-2023-45142/): OpenTelemetry-Go Contrib has DoS vulnerability in otelhttp due to unbound cardinality metrics (high 7.5)
- [CVE-2023-43810](https://insights.sbomify.com/CVE-2023-43810/): opentelemetry-instrumentation Denial of Service vulnerability due to unbound cardinality metrics (high 7.5)
- [CVE-2026-39883](https://insights.sbomify.com/CVE-2026-39883/): opentelemetry-go: BSD kenv command not using absolute path enables PATH hijacking (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40894 and fix it if it is affected.

What it is: CVE-2026-40894 is a medium-severity denial of service vulnerability in open-telemetry OpenTelemetry.Api, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40894 in the wild and no public exploit code.

Affected packages and fixed versions:
- OpenTelemetry.Api (NuGet): affected from 0.5.0-beta.2; fixed in 1.15.3
- OpenTelemetry.Api (NuGet): affected from 0.5.0-beta.2; fixed in 1.15.3
- OpenTelemetry.Extensions.Propagators (NuGet): affected from 1.3.1; fixed in 1.15.3
- OpenTelemetry.Extensions.Propagators (NuGet): affected from 1.3.1; fixed in 1.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40894/ (Markdown: https://insights.sbomify.com/CVE-2026-40894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40894
- OSV: https://osv.dev/vulnerability/CVE-2026-40894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40894/
Summaries are generated and may contain mistakes; the official description above is the record.
