# CVE-2026-40898: quic-go: HTTP/3 QPACK Trailer Expansion Memory Exhaustion

> Attackers can cause memory exhaustion and denial of service in quic-go HTTP/3 implementations by sending malicious QPACK-encoded trailer frames.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 4 Jun 2026
- **Also known as:** CLEANSTART-2026-BH40537, CLEANSTART-2026-OT08451, DEBIAN-CVE-2026-40898, GHSA-vvgj-x9jq-8cj9, GO-2026-5676, MINI-2487-4724-f3mm, MINI-27pc-248q-hrwx, MINI-28jg-8gmr-j6vq, MINI-2xf6-f57g-g4cj, MINI-3hrm-vmcp-656p, MINI-4592-mjv7-gwjx, MINI-49cp-fm9j-6v54, MINI-4j94-4j4h-2gx5, MINI-4xhq-vwx6-vwj3, MINI-55ch-q7xq-85q8, MINI-5jhx-8qgw-w976, MINI-6687-g6fm-4gmv, MINI-6mvm-rj2w-22h2, MINI-72r3-82h3-7547, MINI-7383-9pgr-p36c, MINI-78px-mhvm-7w77, MINI-799g-jg69-wcrh, MINI-7mqj-frgq-w7x5, MINI-8353-338q-hqg4, MINI-83ph-r8pm-5rqv, MINI-85xp-8mm9-qjjv, MINI-8966-w5h8-vxcj, MINI-9f3q-hv78-3qhc, MINI-cgh7-xvfh-998g, MINI-cwqh-m7q5-ww6x, MINI-f3rw-xm43-q4m5, MINI-f4hm-3f6g-wcmv, MINI-fjgw-hgv4-4hgm, MINI-grw4-g7qm-7445, MINI-gvx8-mrmr-7fp7, MINI-hm95-p8cj-3fv7, MINI-j3pc-m3pm-89mr, MINI-j8hc-w2fr-xffv, MINI-j9q5-8745-5gxw, MINI-jp9p-5ww8-hwg3, MINI-m86c-75j3-8gq8, MINI-m8pw-qmwg-mf64, MINI-mrfx-xwp7-mwjf, MINI-p3f6-vmmw-qhj6, MINI-p723-cg95-m9ph, MINI-pj2h-c46h-34wq, MINI-q29v-h2w8-6hfc, MINI-qgxr-vg63-29rv, MINI-qj94-6f5g-cf54, MINI-qpjv-j6q5-fh85, MINI-r8qh-q6j6-8m36, MINI-rm3f-qv9q-m666, MINI-v8m8-j967-7g3x, MINI-v9g8-m8jq-jx72, MINI-v9r5-pg9j-x64q, MINI-wj7f-gxcr-67j9, MINI-wj89-qcg7-gp69, MINI-wjhw-wh88-xq72, MINI-wv34-vhf8-3q58, MINI-wxjw-9qqr-9jf2, MINI-x3hw-xvg6-fq44, MINI-x5j7-gv6r-wgrx, MINI-xv9v-v3qp-r54x, MINI-xwff-w6w6-jjxr, RHSA-2026:40223, RHSA-2026:50318, UBUNTU-CVE-2026-40898

## What is CVE-2026-40898?

CVE-2026-40898 is a medium-severity denial of service vulnerability in quic-go, published on 4 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

quic-go is an implementation of the QUIC protocol in Go. Prior to version 0.59.1, an attacker can cause excessive memory allocation in quic-go's HTTP/3 client and server implementations by sending a QPACK-encoded HEADERS frame that decodes into a large trailer field section with many unique field names and/or large values. The implementation builds an `http.Header` for the corresponding `http.Request` or `http.Response`, while only enforcing limits on the size of the QPACK-compressed HEADERS frame, not on the decoded field section. This can lead to memory exhaustion. This is very similar to CVE-2025-64702. The difference is that this issue uses HTTP trailers, rather than HTTP headers, as the attack vector. A misbehaving or malicious peer can cause a denial-of-service (DoS) attack against quic-go's HTTP/3 servers or clients by triggering excessive memory allocation, potentially leading to crashes or resource exhaustion. This affects both servers and clients due to symmetric header construction. Version 0.59.1 enforces RFC 9114 decoded field section size limits for trailers as well. It incrementally decodes QPACK entries and checks the field section size after each entry, aborting the stream if an entry causes the limit to be exceeded.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-40898?

3 open source packages ship an affected version, including github.com/quic-go/quic-go. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/quic-go/quic-go` | Go | All versions | 0.59.1 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.59.1 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.59.1 |
| `receptor` | Red Hat:ansible_automation_platform:2.7::el10 | All versions | 0:1.6.7-1.el10ap |
| `receptor` | Red Hat:ansible_automation_platform:2.7::el9 | All versions | 0:1.6.7-1.el9ap |
| `receptor` | Red Hat:ansible_automation_platform_inside:2.7::el9 | All versions | 0:1.6.7-1.el9ap |
| `caddy` | Red Hat:hummingbird:1 | All versions | 0:2.11.4-0.2.hum1 |

Products: Quic-Go Project Quic-Go.

## How do I fix CVE-2026-40898?

Upgrade github.com/quic-go/quic-go to 0.59.1 or later.

## Is CVE-2026-40898 being exploited?

There is no known exploitation of CVE-2026-40898 in the wild and no public exploit code.

## Other vulnerabilities in quic-go

- [CVE-2023-46239](https://insights.sbomify.com/CVE-2023-46239/): quic-go vulnerable to pointer dereference that can lead to panic (high 7.5)
- [CVE-2022-30591](https://insights.sbomify.com/CVE-2022-30591/): Denial of service in n/a (high 7.5)
- [CVE-2023-49295](https://insights.sbomify.com/CVE-2023-49295/): quic-go's path validation mechanism can cause denial of service (medium 6.4)
- [CVE-2025-64702](https://insights.sbomify.com/CVE-2025-64702/): quic-go HTTP/3 QPACK Header Expansion DoS (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40898 and fix it if it is affected.

What it is: CVE-2026-40898 is a medium-severity denial of service vulnerability in quic-go, published on 4 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40898 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.59.1
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.59.1
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.59.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40898/ (Markdown: https://insights.sbomify.com/CVE-2026-40898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40898
- OSV: https://osv.dev/vulnerability/CVE-2026-40898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40898/
Summaries are generated and may contain mistakes; the official description above is the record.
