CVE-2026-40902 PhpSpreadsheet: CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions
Attackers can cause CPU exhaustion and denial of service by providing a crafted XLSX file with an invalid row number to applications using PhpSpreadsheet.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-40902?
CVE-2026-40902 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the XLSX reader's ColumnAndRowAttributes::readRowAttributes() method reads row numbers from XML attributes without validating them against the spreadsheet maximum row limit (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a minimal XLSX file (~1.6KB) containing a <row r="999999999"/> element that inflates cachedHighestRow to 999,999,999, causing any subsequent row iteration to attempt ~1 billion loop cycles and exhaust CPU resources. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.
Weakness: CWE-770
Which versions are affected by CVE-2026-40902?
10 open source packages ship an affected version, including phpoffice/phpspreadsheet. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpoffice/phpspreadsheet Packagist | All versions | 1.30.4 |
phpoffice/phpspreadsheet Packagist | All versions | 1.30.4 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.16 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.16 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.5 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.5 |
4 more packages
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.5 |
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.5 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.7.0 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.7.0 |
Products include Phpoffice Phpspreadsheet.
How do I fix CVE-2026-40902?
Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.4, 2.1.16, 2.4.5 or 3.10.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-40902 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40902 exists.
Other vulnerabilities in PHPOffice PhpSpreadsheet
- CVE-2026-34084 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load
- CVE-2024-45048 XML External Entity Reference (XXE) in PHPSpreadsheet
- CVE-2019-12331 XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue
- CVE-2018-19277 XXE in PHPSpreadsheet due to encoding issue
- CVE-2024-56365 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class
Sources
Also known as GHSA-7c6m-4442-2x6m.