# CVE-2026-40902: PhpSpreadsheet: CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions

> Attackers can cause CPU exhaustion and denial of service by providing a crafted XLSX file with an invalid row number to applications using PhpSpreadsheet.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-7c6m-4442-2x6m

## What is CVE-2026-40902?

CVE-2026-40902 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the XLSX reader's ColumnAndRowAttributes::readRowAttributes() method reads row numbers from XML attributes without validating them against the spreadsheet maximum row limit (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a minimal XLSX file (~1.6KB) containing a <row r="999999999"/> element that inflates cachedHighestRow to 999,999,999, causing any subsequent row iteration to attempt ~1 billion loop cycles and exhaust CPU resources. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-40902?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.4 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.4 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.16 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.16 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.7.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.7.0 |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2026-40902?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.4, 2.1.16, 2.4.5 or 3.10.5.

## Is CVE-2026-40902 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40902 exists.

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40902 and fix it if it is affected.

What it is: CVE-2026-40902 is a high-severity denial of service vulnerability in PHPOffice PhpSpreadsheet, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40902 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.4
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.4
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.16
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.16
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.5
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.5
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.5
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.5
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.7.0
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40902/ (Markdown: https://insights.sbomify.com/CVE-2026-40902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40902
- OSV: https://osv.dev/vulnerability/CVE-2026-40902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40902/
Summaries are generated and may contain mistakes; the official description above is the record.
