CVE-2026-40910 frp: Authentication bypass in frp HTTP vhost routing when routeByHTTPUser is used for access control

Medium 6.5 Published Updated

Attackers can bypass authentication in frp HTTP vhost routing when routeByHTTPUser is enabled, accessing protected backends with incorrect credentials.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40910?

CVE-2026-40910 is a medium-severity authentication bypass vulnerability in fatedier frp, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

frp is a fast reverse proxy. From 0.43.0 to 0.68.0, frp contains an authentication bypass in the HTTP vhost routing path when routeByHTTPUser is used as part of access control. In proxy-style requests, the routing logic uses the username from Proxy-Authorization to select the routeByHTTPUser backend, while the access control check uses credentials from the regular Authorization header. As a result, an attacker who can reach the HTTP vhost entrypoint and knows or can guess the protected routeByHTTPUser value may access a backend protected by httpUser / httpPassword even with an incorrect Proxy-Authorization password. This issue affects deployments that explicitly use routeByHTTPUser. It does not affect ordinary HTTP proxies that do not use this feature. This vulnerability is fixed in 0.68.1.

Weakness: CWE-287

Which versions are affected by CVE-2026-40910?

3 open source packages ship an affected version, including github.com/fatedier/frp. It affects 1 product.

PackageAffectedFixed in
github.com/fatedier/frp GoFrom 0.43.00.68.1
github.com/fatedier/frp GoFrom 0.43.00.68.1
github.com/fatedier/frp GoFrom 0.43.00.68.1

Products include Fatedier Frp.

How do I fix CVE-2026-40910?

Upgrade github.com/fatedier/frp to 0.68.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-40910 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40910 exists.

Sources

Also known as GHSA-pq96-pwvg-vrr9, GO-2026-5549.

Is CVE-2026-40910 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free