# CVE-2026-40910: frp: Authentication bypass in frp HTTP vhost routing when routeByHTTPUser is used for access control

> Attackers can bypass authentication in frp HTTP vhost routing when routeByHTTPUser is enabled, accessing protected backends with incorrect credentials.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-pq96-pwvg-vrr9, GO-2026-5549

## What is CVE-2026-40910?

CVE-2026-40910 is a medium-severity authentication bypass vulnerability in fatedier frp, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

frp is a fast reverse proxy. From 0.43.0 to 0.68.0, frp contains an authentication bypass in the HTTP vhost routing path when routeByHTTPUser is used as part of access control. In proxy-style requests, the routing logic uses the username from Proxy-Authorization to select the routeByHTTPUser backend, while the access control check uses credentials from the regular Authorization header. As a result, an attacker who can reach the HTTP vhost entrypoint and knows or can guess the protected routeByHTTPUser value may access a backend protected by httpUser / httpPassword even with an incorrect Proxy-Authorization password. This issue affects deployments that explicitly use routeByHTTPUser. It does not affect ordinary HTTP proxies that do not use this feature. This vulnerability is fixed in 0.68.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-40910?

3 open source packages ship an affected version, including github.com/fatedier/frp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fatedier/frp` | Go | From 0.43.0 | 0.68.1 |
| `github.com/fatedier/frp` | Go | From 0.43.0 | 0.68.1 |
| `github.com/fatedier/frp` | Go | From 0.43.0 | 0.68.1 |

Products: Fatedier Frp.

## How do I fix CVE-2026-40910?

Upgrade github.com/fatedier/frp to 0.68.1 or later.

## Is CVE-2026-40910 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40910 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40910 and fix it if it is affected.

What it is: CVE-2026-40910 is a medium-severity authentication bypass vulnerability in fatedier frp, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40910 exists.

Affected packages and fixed versions:
- github.com/fatedier/frp (Go): affected from 0.43.0; fixed in 0.68.1
- github.com/fatedier/frp (Go): affected from 0.43.0; fixed in 0.68.1
- github.com/fatedier/frp (Go): affected from 0.43.0; fixed in 0.68.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40910/ (Markdown: https://insights.sbomify.com/CVE-2026-40910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40910
- OSV: https://osv.dev/vulnerability/CVE-2026-40910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40910/
Summaries are generated and may contain mistakes; the official description above is the record.
