# CVE-2026-40914: Apache Artemis has an Incorrect Authorization issue

> STOMP users with send or consume permissions can modify address routing types without createAddress permission, allowing unauthorized configuration changes.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-rf99-f9j2-gv3f, MINI-785r-476q-mh84, MINI-pqc8-2343-c6w6

## What is CVE-2026-40914?

CVE-2026-40914 is a medium-severity missing authorization vulnerability in Apache ActiveMQ Artemis Stomp Protocol, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability exists in Apache Artemis whereby an application using the STOMP protocol with security credentials that grant either the consume or send permission on an address can augment the routing-type supported by that address even if said user doesn't have the createAddress permission for that particular address. A user could successfully send a message to an address or consume a message from a queue with a routing-type not supported by the corresponding address when that operation should actually be rejected on the basis that the user doesn't have permission to change the routing-type of the address. Even though the user was already granted permission to send and/or consume messages, they should not be able to augment the routing-type of the address without the createAddress permission.

This issue affects Apache Artemis: from 2.50.0 through 2.53.0; Apache ActiveMQ Artemis: from 2.0.0 through 2.44.0.

Users are recommended to upgrade to version 2.54.0, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-40914?

4 open source packages ship an affected version, including org.apache.artemis:artemis-stomp-protocol. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.artemis:artemis-stomp-protocol` | Maven | From 2.0.0 to 2.44.0 | None |
| `org.apache.artemis:artemis-stomp-protocol` | Maven | From 2.0.0 to 2.44.0 | None |
| `org.apache.artemis:artemis-stomp-protocol` | Maven | From 2.50.0 | 2.54.0 |
| `org.apache.artemis:artemis-stomp-protocol` | Maven | From 2.50.0 | 2.54.0 |

Products: Apache Artemis.

## How do I fix CVE-2026-40914?

Upgrade org.apache.artemis:artemis-stomp-protocol to 2.54.0 or later.

## Is CVE-2026-40914 being exploited?

There is no known exploitation of CVE-2026-40914 in the wild and no public exploit code.

## Other vulnerabilities in Apache ActiveMQ Artemis Stomp Protocol

- [CVE-2026-57967](https://insights.sbomify.com/CVE-2026-57967/): Apache Artemis, Apache ActiveMQ Artemis: Missing authentication on CORE protocol session reattachment (critical 9.8)
- [CVE-2026-27446](https://insights.sbomify.com/CVE-2026-27446/): Apache Artemis, Apache ActiveMQ Artemis: Auth bypass for Core downstream federation (critical 9.3)
- [CVE-2026-49364](https://insights.sbomify.com/CVE-2026-49364/): Information disclosure in Apache ActiveMQ Artemis (critical 9.1)
- [CVE-2026-67593](https://insights.sbomify.com/CVE-2026-67593/): Missing authorization in Apache ActiveMQ Artemis (critical 9.1)
- [CVE-2023-50780](https://insights.sbomify.com/CVE-2023-50780/): Apache ActiveMQ Artemis: Authenticated users could perform RCE via Jolokia MBeans (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40914 and fix it if it is affected.

What it is: CVE-2026-40914 is a medium-severity missing authorization vulnerability in Apache ActiveMQ Artemis Stomp Protocol, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40914 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.artemis:artemis-stomp-protocol (Maven): affected from 2.0.0 up to 2.44.0; no fix listed
- org.apache.artemis:artemis-stomp-protocol (Maven): affected from 2.0.0 up to 2.44.0; no fix listed
- org.apache.artemis:artemis-stomp-protocol (Maven): affected from 2.50.0; fixed in 2.54.0
- org.apache.artemis:artemis-stomp-protocol (Maven): affected from 2.50.0; fixed in 2.54.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40914/ (Markdown: https://insights.sbomify.com/CVE-2026-40914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40914
- OSV: https://osv.dev/vulnerability/CVE-2026-40914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40914/
Summaries are generated and may contain mistakes; the official description above is the record.
