# CVE-2026-4092: Arbitrary File Write via Path Traversal in Google clasp leading to RCE

> A remote attacker can achieve remote code execution by exploiting a path traversal vulnerability in Google Clasp via malicious filenames in Apps Script projects.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-hqjg-pww4-pcgq

## What is CVE-2026-4092?

CVE-2026-4092 is a high-severity path traversal vulnerability in Google Clasp, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Path Traversal in Clasp impacting versions < 3.2.0 allows a remote attacker to perform remote code execution via a malicious Google Apps Script project containing specially crafted filenames with directory traversal sequences.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-4092?

2 open source packages ship an affected version, including @google/clasp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@google/clasp` | npm | All versions | 3.2.0 |
| `@google/clasp` | npm | All versions | 3.2.0 |

Products: Google Clasp.

## How do I fix CVE-2026-4092?

Upgrade @google/clasp to 3.2.0 or later.

## Is CVE-2026-4092 being exploited?

There is no known exploitation of CVE-2026-4092 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4092 and fix it if it is affected.

What it is: CVE-2026-4092 is a high-severity path traversal vulnerability in Google Clasp, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-4092 in the wild and no public exploit code.

Affected packages and fixed versions:
- @google/clasp (npm): affected all versions; fixed in 3.2.0
- @google/clasp (npm): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4092/ (Markdown: https://insights.sbomify.com/CVE-2026-4092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4092
- OSV: https://osv.dev/vulnerability/CVE-2026-4092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4092/
Summaries are generated and may contain mistakes; the official description above is the record.
