# CVE-2026-40920: Apache Ranger: Privilege Escalation via URL Parameter


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-8q3p-j6v6-5x63

## What is CVE-2026-40920?

CVE-2026-40920 is a critical vulnerability in Apache Ranger, published on 10 Aug 2026. 

### Official description

Privilege Escalation via URL Parameter is reported in Apache Ranger versions <= 2.8.0.

Users are recommended to upgrade to version 2.9.0, which fixes this issue.

Weakness: CWE-287 (Improper Authentication), CWE-269 (Improper Privilege Management), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-40920?

It affects 1 product.


Products: Apache Ranger.

## How do I fix CVE-2026-40920?

No fix has been published for CVE-2026-40920 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-40920 being exploited?

There is no known exploitation of CVE-2026-40920 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ranger

- [CVE-2026-28672](https://insights.sbomify.com/CVE-2026-28672/): Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder (critical 9.8)
- [CVE-2026-32227](https://insights.sbomify.com/CVE-2026-32227/): Apache Ranger: SQL Injection vulnerability in lookup functionality (critical 9.8)
- [CVE-2026-42537](https://insights.sbomify.com/CVE-2026-42537/): Apache Ranger: Remote Code Execution via JDBC URL Injection (critical 9.8)
- [CVE-2026-44416](https://insights.sbomify.com/CVE-2026-44416/): Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation (critical 9.8)
- [CVE-2026-55799](https://insights.sbomify.com/CVE-2026-55799/): Apache Ranger: Remote Code Execution Vulnerability in GraalScriptEngineCreator (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40920 and fix it if it is affected.

What it is: CVE-2026-40920 is a critical vulnerability in Apache Ranger, published on 10 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-40920 in the wild and no public exploit code.

Affected product: Apache Ranger. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40920/ (Markdown: https://insights.sbomify.com/CVE-2026-40920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40920
- OSV: https://osv.dev/vulnerability/CVE-2026-40920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40920/
Summaries are generated and may contain mistakes; the official description above is the record.
