# CVE-2026-40927: Docmost: XSS in Comments with JavaScript URI

> Attackers can inject JavaScript via comments in Docmost, allowing code execution when users click malicious links.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Apr 2026
- **Updated:** 22 Apr 2026

## What is CVE-2026-40927?

CVE-2026-40927 is a medium-severity cross-site scripting vulnerability in docmost, published on 21 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Docmost is open-source collaborative wiki and documentation software. Prior to 0.80.0, when leaving a comment on a page, it is possible to include a JavaScript URI as the link. When a user clicks on the link the JavaScript executes. This vulnerability is fixed in 0.80.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-40927?

It affects 1 product.


Products: Docmost Docmost.

## How do I fix CVE-2026-40927?

No fix has been published for CVE-2026-40927 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-40927 being exploited?

There is no known exploitation of CVE-2026-40927 in the wild and no public exploit code.

## Other vulnerabilities in docmost

- [CVE-2026-24045](https://insights.sbomify.com/CVE-2026-24045/): Docmost Affected by Stored XSS in Public Share Page (high 7.3)
- [CVE-2026-22249](https://insights.sbomify.com/CVE-2026-22249/): Docmost affected by an Arbitrary File Write via Zip Import Feature (ZipSlip) (high 7.1)
- [CVE-2026-23630](https://insights.sbomify.com/CVE-2026-23630/): Docmost is vulnerable to stored Cross-Site Scripting (XSS) through Mermaid rendering (medium 6.3)
- [CVE-2025-55574](https://insights.sbomify.com/CVE-2025-55574/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2026-34212](https://insights.sbomify.com/CVE-2026-34212/): Docmost page content has stored XSS via unsanitized attachment URLs (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40927 and fix it if it is affected.

What it is: CVE-2026-40927 is a medium-severity cross-site scripting vulnerability in docmost, published on 21 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-40927 in the wild and no public exploit code.

Affected product: docmost. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40927/ (Markdown: https://insights.sbomify.com/CVE-2026-40927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40927
- OSV: https://osv.dev/vulnerability/CVE-2026-40927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40927/
Summaries are generated and may contain mistakes; the official description above is the record.
