# CVE-2026-40934: jupyter-server authentication cookies remain valid after password reset due to static cookie secret

> Attackers retain authenticated access after password resets because Jupyter Server fails to rotate the cookie signing secret, allowing session hijacking.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 7 May 2026
- **Also known as:** CLEANSTART-2026-HV39439, CLEANSTART-2026-PZ41099, DEBIAN-CVE-2026-40934, GHSA-5mrq-x3x5-8v8f, PYSEC-2026-69, UBUNTU-CVE-2026-40934

## What is CVE-2026-40934?

CVE-2026-40934 is a high-severity authentication bypass vulnerability in jupyter-server jupyter_server, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, the secret used to sign authentication cookies is persisted to a static file at ~/.local/share/jupyter/runtime/jupyter_cookie_secret and is never rotated when a user changes their password. After a password reset and server restart, any previously issued authentication cookie remains cryptographically valid because the signing key has not changed. An attacker who has captured a session cookie through any means retains full authenticated access to the server regardless of subsequent password changes. This affects deployments using password-based authentication, particularly shared or public-facing servers where credential rotation is expected to revoke existing sessions. This issue has been fixed in version 2.18.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-40934?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2026-40934?

Upgrade jupyter-server to 2.18.0 or later.

## Is CVE-2026-40934 being exploited?

There is no known exploitation of CVE-2026-40934 in the wild and no public exploit code.

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-35397](https://insights.sbomify.com/CVE-2026-35397/): jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix (high 7.6)
- [CVE-2026-40110](https://insights.sbomify.com/CVE-2026-40110/): jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat (high 7.6)
- [CVE-2024-35178](https://insights.sbomify.com/CVE-2024-35178/): Jupyter server on Windows discloses Windows user password hash (high 7.5)
- [CVE-2022-24757](https://insights.sbomify.com/CVE-2022-24757/): Sensitive Auth & Cookie data stored in Jupyter server logs (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40934 and fix it if it is affected.

What it is: CVE-2026-40934 is a high-severity authentication bypass vulnerability in jupyter-server jupyter_server, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40934 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40934/ (Markdown: https://insights.sbomify.com/CVE-2026-40934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40934
- OSV: https://osv.dev/vulnerability/CVE-2026-40934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40934/
Summaries are generated and may contain mistakes; the official description above is the record.
