# CVE-2026-40941: Cacti: Package Import Signature Validation Bypass Allows Self-Signed Packages

> Attackers can bypass signature validation to install self-signed packages in Cacti, potentially leading to code execution.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-40941, GHSA-274c-97hj-pv2v, UBUNTU-CVE-2026-40941

## What is CVE-2026-40941?

CVE-2026-40941 is a high-severity vulnerability in Cacti Cacti, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have a package import signature validation bypass allows which allows self-signed packages. This issue has been fixed in version 1.2.31.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-40941?

It affects 1 product.


Products: Cacti Cacti.

## How do I fix CVE-2026-40941?

Upgrade to a fixed version.

## Is CVE-2026-40941 being exploited?

There is no known exploitation of CVE-2026-40941 in the wild and no public exploit code.

## Other vulnerabilities in Cacti Cacti

- [CVE-2022-46169](https://insights.sbomify.com/CVE-2022-46169/): Cacti Command Injection (critical 9.8, exploited in the wild)
- [CVE-2026-39893](https://insights.sbomify.com/CVE-2026-39893/): Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php (critical 9.8)
- [CVE-2026-39938](https://insights.sbomify.com/CVE-2026-39938/): Cacti: Unauthenticated RCE on Graph Image (critical 9.8)
- [CVE-2026-39955](https://insights.sbomify.com/CVE-2026-39955/): Cacti has Pre-Authentication SQL Injection via unanchored FILTER_VALIDATE_REGEXP in graph_view.php (critical 9.8)
- [CVE-2023-39361](https://insights.sbomify.com/CVE-2023-39361/): Unauthenticated SQL Injection in graph_view.php in Cacti (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40941 and fix it if it is affected.

What it is: CVE-2026-40941 is a high-severity vulnerability in Cacti Cacti, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40941 in the wild and no public exploit code.

Affected product: Cacti Cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40941/ (Markdown: https://insights.sbomify.com/CVE-2026-40941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40941
- OSV: https://osv.dev/vulnerability/CVE-2026-40941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40941/
Summaries are generated and may contain mistakes; the official description above is the record.
