{"answers":{"affected":"3 open source packages ship an affected version, including github.com/oxia-db/oxia.","exploited":"There is no known exploitation of CVE-2026-40944 in the wild and no public exploit code.","fix":"Upgrade github.com/oxia-db/oxia to 0.16.2 or later.","what":"CVE-2026-40944 is a medium-severity vulnerability in oxia-db oxia, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40944 and fix it if it is affected.\n\nWhat it is: CVE-2026-40944 is a medium-severity vulnerability in oxia-db oxia, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40944 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/oxia-db/oxia (Go): affected all versions; fixed in 0.16.2\n- github.com/oxia-db/oxia (Go): affected all versions; fixed in 0.16.2\n- github.com/oxia-db/oxia (Go): affected all versions; fixed in 0.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40944/ (Markdown: https://insights.sbomify.com/CVE-2026-40944/index.md)","id":"CVE-2026-40944","markdown":"https://insights.sbomify.com/CVE-2026-40944/index.md","name":"CVE-2026-40944","record":{"aliases":["GHSA-7jrq-q4pq-rhm6","GO-2026-5226"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Oxia metadata store","requires_auth":"none","summary":"Attackers can bypass TLS certificate chain validation in Oxia by exploiting a bug that ignores multiple certificates in CA bundles, undermining mTLS security.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Oxia is a metadata store and coordination system. Prior to 0.16.2, the trustedCertPool() function in the TLS configuration only parses the first PEM block from CA certificate files. When a CA bundle contains multiple certificates (e.g., intermediate + root CA), only the first certificate is loaded. This silently breaks certificate chain validation for mTLS. This vulnerability is fixed in 0.16.2.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Oxia: TLS CA certificate chain validation fails with multi-certificate PEM bundles","id":"CVE-2026-40944","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Oxia: Bearer token exposed in debug log messages on authentication failure","id":"CVE-2026-40945"},"packages":[{"ecosystem":"Go","fixed":["0.16.2"],"introduced":["0"],"last_affected":[],"package":"github.com/oxia-db/oxia","purl":null,"source":"GHSA-7jrq-q4pq-rhm6"},{"ecosystem":"Go","fixed":["0.16.2"],"introduced":["0"],"last_affected":[],"package":"github.com/oxia-db/oxia","purl":"pkg:golang/github.com/oxia-db/oxia","source":"GHSA-7jrq-q4pq-rhm6"},{"ecosystem":"Go","fixed":["0.16.2"],"introduced":["0"],"last_affected":[],"package":"github.com/oxia-db/oxia","purl":"pkg:golang/github.com/oxia-db/oxia","source":"GO-2026-5226"}],"prev":{"headline":"Oxia: Server crash via race condition in session heartbeat handling","id":"CVE-2026-40943"},"products":["oxia"],"published":"2026-04-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-22","vendors":["oxia-db"]},"summary":"Attackers can bypass TLS certificate chain validation in Oxia by exploiting a bug that ignores multiple certificates in CA bundles, undermining mTLS security.","url":"https://insights.sbomify.com/CVE-2026-40944/"}