# CVE-2026-40944: Oxia: TLS CA certificate chain validation fails with multi-certificate PEM bundles

> Attackers can bypass TLS certificate chain validation in Oxia by exploiting a bug that ignores multiple certificates in CA bundles, undermining mTLS security.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** GHSA-7jrq-q4pq-rhm6, GO-2026-5226

## What is CVE-2026-40944?

CVE-2026-40944 is a medium-severity vulnerability in oxia-db oxia, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Oxia is a metadata store and coordination system. Prior to 0.16.2, the trustedCertPool() function in the TLS configuration only parses the first PEM block from CA certificate files. When a CA bundle contains multiple certificates (e.g., intermediate + root CA), only the first certificate is loaded. This silently breaks certificate chain validation for mTLS. This vulnerability is fixed in 0.16.2.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-40944?

3 open source packages ship an affected version, including github.com/oxia-db/oxia.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/oxia-db/oxia` | Go | All versions | 0.16.2 |
| `github.com/oxia-db/oxia` | Go | All versions | 0.16.2 |
| `github.com/oxia-db/oxia` | Go | All versions | 0.16.2 |

## How do I fix CVE-2026-40944?

Upgrade github.com/oxia-db/oxia to 0.16.2 or later.

## Is CVE-2026-40944 being exploited?

There is no known exploitation of CVE-2026-40944 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40944 and fix it if it is affected.

What it is: CVE-2026-40944 is a medium-severity vulnerability in oxia-db oxia, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40944 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/oxia-db/oxia (Go): affected all versions; fixed in 0.16.2
- github.com/oxia-db/oxia (Go): affected all versions; fixed in 0.16.2
- github.com/oxia-db/oxia (Go): affected all versions; fixed in 0.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40944/ (Markdown: https://insights.sbomify.com/CVE-2026-40944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40944
- OSV: https://osv.dev/vulnerability/CVE-2026-40944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40944/
Summaries are generated and may contain mistakes; the official description above is the record.
