# CVE-2026-40975: Spring Boot's random value property source uses a weak PRNG unsuitable for secrets

> Developers using Spring Boot random value properties for secrets risk exposure due to predictable PRNG output, requiring upgrades to secure versions.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-m4x9-hx6x-2c43

## What is CVE-2026-40975?

CVE-2026-40975 is a medium-severity vulnerability in Spring Boot, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Values produced by ${random.value} are not suitable for use as secrets. ${random.uuid} is not affected. ${random.int} and ${random.long} should never be used for secrets as they are numeric values with a predictable range.

Affected: Spring Boot 4.0.0–4.0.5 (fix 4.0.6), 3.5.0–3.5.13 (fix 3.5.14), 3.4.0–3.4.15 (fix 3.4.16), 3.3.0–3.3.18 (fix 3.3.19), 2.7.0–2.7.32 (fix 2.7.33); random value property source / weak PRNG for secrets. Versions that are no longer supported are also affected per vendor advisory.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)), CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2026-40975?

10 open source packages ship an affected version, including org.springframework.boot:spring-boot-cassandra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.boot:spring-boot-cassandra` | Maven | All versions to 2.7.32 | None |
| `org.springframework.boot:spring-boot-cassandra` | Maven | All versions to 2.7.32 | None |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 3.3.0 to 3.3.18 | None |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 3.3.0 to 3.3.18 | None |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 3.4.0 to 3.4.15 | None |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 3.4.0 to 3.4.15 | None |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 3.5.0 | 3.5.14 |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 3.5.0 | 3.5.14 |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 4.0.0 | 4.0.6 |
| `org.springframework.boot:spring-boot-cassandra` | Maven | From 4.0.0 | 4.0.6 |

Products: Vmware Spring Boot.

## How do I fix CVE-2026-40975?

Upgrade org.springframework.boot:spring-boot-cassandra to a fixed version for your release line: 3.5.14 or 4.0.6.

## Is CVE-2026-40975 being exploited?

There is no known exploitation of CVE-2026-40975 in the wild and no public exploit code.

## Other vulnerabilities in Spring Boot

- [CVE-2023-20873](https://insights.sbomify.com/CVE-2023-20873/): Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry (critical 9.8)
- [CVE-2026-40976](https://insights.sbomify.com/CVE-2026-40976/): Spring Boot's default security filter chain has no authorization rule with Actuator but without Health (critical 9.1)
- [CVE-2026-22731](https://insights.sbomify.com/CVE-2026-22731/): Authentication Bypass under Actuator Health groups paths (high 8.2)
- [CVE-2026-22733](https://insights.sbomify.com/CVE-2026-22733/): Authentication Bypass under Actuator CloudFoundry endpoints (high 8.2)
- [CVE-2022-27772](https://insights.sbomify.com/CVE-2022-27772/): Temporary Directory Hijacking to Local Privilege Escalation Vulnerability in org.springframework.boot:spring-boot (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40975 and fix it if it is affected.

What it is: CVE-2026-40975 is a medium-severity vulnerability in Spring Boot, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40975 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.boot:spring-boot-cassandra (Maven): affected all versions up to 2.7.32; no fix listed
- org.springframework.boot:spring-boot-cassandra (Maven): affected all versions up to 2.7.32; no fix listed
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 3.3.0 up to 3.3.18; no fix listed
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 3.3.0 up to 3.3.18; no fix listed
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 3.4.0 up to 3.4.15; no fix listed
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 3.4.0 up to 3.4.15; no fix listed
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 3.5.0; fixed in 3.5.14
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 3.5.0; fixed in 3.5.14
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 4.0.0; fixed in 4.0.6
- org.springframework.boot:spring-boot-cassandra (Maven): affected from 4.0.0; fixed in 4.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40975/ (Markdown: https://insights.sbomify.com/CVE-2026-40975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40975
- OSV: https://osv.dev/vulnerability/CVE-2026-40975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40975/
Summaries are generated and may contain mistakes; the official description above is the record.
