# CVE-2026-40976: Spring Boot's default security filter chain has no authorization rule with Actuator but without Health

> Attackers can access all endpoints in specific Spring Boot configurations lacking custom security, leading to unauthorized data exposure or modification.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-KC47770, CLEANSTART-2026-UJ95320, GHSA-8v8j-3hxp-93wr, MINI-235v-2h4r-f866, ROOT-APP-MAVEN-CVE-2026-40976

## What is CVE-2026-40976?

CVE-2026-40976 is a critical missing authorization vulnerability in Spring Boot, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable.

Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-40976?

2 open source packages ship an affected version, including org.springframework.boot:spring-boot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.boot:spring-boot` | Maven | From 4.0.0 | 4.0.6 |
| `org.springframework.boot:spring-boot` | Maven | From 4.0.0 | 4.0.6 |

Products: Vmware Spring Boot.

## How do I fix CVE-2026-40976?

Upgrade org.springframework.boot:spring-boot to 4.0.6 or later.

## Is CVE-2026-40976 being exploited?

There is no known exploitation of CVE-2026-40976 in the wild and no public exploit code.

Public exploit code:

- https://github.com/madebyrokit/CVE-2026-40976-POC (github_poc): https://github.com/madebyrokit/CVE-2026-40976-POC

## Other vulnerabilities in Spring Boot

- [CVE-2023-20873](https://insights.sbomify.com/CVE-2023-20873/): Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry (critical 9.8)
- [CVE-2026-22731](https://insights.sbomify.com/CVE-2026-22731/): Authentication Bypass under Actuator Health groups paths (high 8.2)
- [CVE-2026-22733](https://insights.sbomify.com/CVE-2026-22733/): Authentication Bypass under Actuator CloudFoundry endpoints (high 8.2)
- [CVE-2022-27772](https://insights.sbomify.com/CVE-2022-27772/): Temporary Directory Hijacking to Local Privilege Escalation Vulnerability in org.springframework.boot:spring-boot (high 7.8)
- [CVE-2026-40972](https://insights.sbomify.com/CVE-2026-40972/): Spring Boot DevTools remote secret comparison is vulnerable to timing attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40976 and fix it if it is affected.

What it is: CVE-2026-40976 is a critical missing authorization vulnerability in Spring Boot, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40976 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.boot:spring-boot (Maven): affected from 4.0.0; fixed in 4.0.6
- org.springframework.boot:spring-boot (Maven): affected from 4.0.0; fixed in 4.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40976/ (Markdown: https://insights.sbomify.com/CVE-2026-40976/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40976
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40976
- OSV: https://osv.dev/vulnerability/CVE-2026-40976

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40976/
Summaries are generated and may contain mistakes; the official description above is the record.
