# CVE-2026-40985: Data Binding Vulnerability in Spring Web Flow with Unified EL Parser

> Attackers can execute arbitrary code via malicious Unified EL expressions in applications using Spring Web Flow with specific parser configurations.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-9ggw-87m9-9gfc

## What is CVE-2026-40985?

CVE-2026-40985 is a medium-severity code injection vulnerability in Spring Web Flow, published on 11 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions.

Affected versions:
Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2026-40985?

6 open source packages ship an affected version, including org.springframework.webflow:spring-webflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.webflow:spring-webflow` | Maven | All versions to 2.5.1 | None |
| `org.springframework.webflow:spring-webflow` | Maven | All versions to 2.5.1 | None |
| `org.springframework.webflow:spring-webflow` | Maven | From 3.0.0 | 3.0.2 |
| `org.springframework.webflow:spring-webflow` | Maven | From 3.0.0 | 3.0.2 |
| `org.springframework.webflow:spring-webflow` | Maven | From 4.0.0 | 4.0.1 |
| `org.springframework.webflow:spring-webflow` | Maven | From 4.0.0 | 4.0.1 |

Products: Broadcom Spring Web Flow.

## How do I fix CVE-2026-40985?

Upgrade org.springframework.webflow:spring-webflow to a fixed version for your release line: 3.0.2 or 4.0.1.

## Is CVE-2026-40985 being exploited?

There is no known exploitation of CVE-2026-40985 in the wild and no public exploit code.

## Other vulnerabilities in Spring Web Flow

- [CVE-2017-8039](https://insights.sbomify.com/CVE-2017-8039/): Insecure Default Initialization of Resource in Pivotal Spring Web Flow (medium 5.9)
- [CVE-2017-4971](https://insights.sbomify.com/CVE-2017-4971/): Insecure Default Initialization of Resource in Pivotal Spring Web Flow (medium 5.9)
- [CVE-2026-40986](https://insights.sbomify.com/CVE-2026-40986/): Spring Web Flow JS RemotingHandler renders non-HTML Response as HTML (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40985 and fix it if it is affected.

What it is: CVE-2026-40985 is a medium-severity code injection vulnerability in Spring Web Flow, published on 11 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-40985 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.webflow:spring-webflow (Maven): affected all versions up to 2.5.1; no fix listed
- org.springframework.webflow:spring-webflow (Maven): affected all versions up to 2.5.1; no fix listed
- org.springframework.webflow:spring-webflow (Maven): affected from 3.0.0; fixed in 3.0.2
- org.springframework.webflow:spring-webflow (Maven): affected from 3.0.0; fixed in 3.0.2
- org.springframework.webflow:spring-webflow (Maven): affected from 4.0.0; fixed in 4.0.1
- org.springframework.webflow:spring-webflow (Maven): affected from 4.0.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40985/ (Markdown: https://insights.sbomify.com/CVE-2026-40985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40985
- OSV: https://osv.dev/vulnerability/CVE-2026-40985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40985/
Summaries are generated and may contain mistakes; the official description above is the record.
