# CVE-2026-40986: Spring Web Flow JS RemotingHandler renders non-HTML Response as HTML

> Attackers can execute scripts in user browsers via reflected input in error responses rendered as HTML by Spring Web Flow's RemotingHandler.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-hw5c-xm3c-v96w, ROOT-APP-MAVEN-CVE-2026-40986

## What is CVE-2026-40986?

CVE-2026-40986 is a medium-severity cross-site scripting vulnerability in Spring Web Flow, published on 11 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Spring Web Flow's JavaScript RemotingHandler renders the body of an error response as HTML even when the response is not "text/html", which can result in a scripting attack in the user's browser if the error response from the server contains error details with input reflected from an attacker.

Affected versions:
Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-40986?

6 open source packages ship an affected version, including org.springframework.webflow:spring-webflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.webflow:spring-webflow` | Maven | All versions to 2.5.1 | None |
| `org.springframework.webflow:spring-webflow` | Maven | All versions to 2.5.1 | None |
| `org.springframework.webflow:spring-webflow` | Maven | From 3.0.0 | 3.0.2 |
| `org.springframework.webflow:spring-webflow` | Maven | From 3.0.0 | 3.0.2 |
| `org.springframework.webflow:spring-webflow` | Maven | From 4.0.0 | 4.0.1 |
| `org.springframework.webflow:spring-webflow` | Maven | From 4.0.0 | 4.0.1 |

Products: Broadcom Spring Web Flow.

## How do I fix CVE-2026-40986?

Upgrade org.springframework.webflow:spring-webflow to a fixed version for your release line: 3.0.2 or 4.0.1.

## Is CVE-2026-40986 being exploited?

There is no known exploitation of CVE-2026-40986 in the wild and no public exploit code.

## Other vulnerabilities in Spring Web Flow

- [CVE-2026-40985](https://insights.sbomify.com/CVE-2026-40985/): Data Binding Vulnerability in Spring Web Flow with Unified EL Parser (medium 6.4)
- [CVE-2017-8039](https://insights.sbomify.com/CVE-2017-8039/): Insecure Default Initialization of Resource in Pivotal Spring Web Flow (medium 5.9)
- [CVE-2017-4971](https://insights.sbomify.com/CVE-2017-4971/): Insecure Default Initialization of Resource in Pivotal Spring Web Flow (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40986 and fix it if it is affected.

What it is: CVE-2026-40986 is a medium-severity cross-site scripting vulnerability in Spring Web Flow, published on 11 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-40986 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.webflow:spring-webflow (Maven): affected all versions up to 2.5.1; no fix listed
- org.springframework.webflow:spring-webflow (Maven): affected all versions up to 2.5.1; no fix listed
- org.springframework.webflow:spring-webflow (Maven): affected from 3.0.0; fixed in 3.0.2
- org.springframework.webflow:spring-webflow (Maven): affected from 3.0.0; fixed in 3.0.2
- org.springframework.webflow:spring-webflow (Maven): affected from 4.0.0; fixed in 4.0.1
- org.springframework.webflow:spring-webflow (Maven): affected from 4.0.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40986/ (Markdown: https://insights.sbomify.com/CVE-2026-40986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40986
- OSV: https://osv.dev/vulnerability/CVE-2026-40986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40986/
Summaries are generated and may contain mistakes; the official description above is the record.
