CVE-2026-40988 Unbounded DEFLATE Inflation in SAML 2.0 Service Provider
Attackers can cause denial of service by sending compressed SAML payloads that exhaust memory during inflation in applications using the REDIRECT binding.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-40988?
CVE-2026-40988 is a high-severity denial of service vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory.
Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.
Weakness: CWE-400
Which versions are affected by CVE-2026-40988?
12 open source packages ship an affected version, including org.springframework.security:spring-security-saml2-service-provider. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-saml2-service-provider Maven | All versions to 5.7.23 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | All versions to 5.7.23 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 5.8.0 to 5.8.25 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 5.8.0 to 5.8.25 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.3.0 to 6.3.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.3.0 to 6.3.16 | None |
6 more packages
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.4.0 to 6.4.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.4.0 to 6.4.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.5.0 | 6.5.11 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.5.0 | 6.5.11 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 7.0.0 | 7.0.6 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 7.0.0 | 7.0.6 |
Products include Vmware Spring Security.
How do I fix CVE-2026-40988?
Upgrade org.springframework.security:spring-security-saml2-service-provider to a fixed version for your release line: 6.5.11 or 7.0.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-40988 being exploited?
There is no known exploitation of CVE-2026-40988 in the wild and no public exploit code.
Other vulnerabilities in Spring Security
- CVE-2014-3527 Authorization Bypass in Spring Security
- CVE-2026-59354 Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata
- CVE-2026-59270 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces
- CVE-2026-22732 Under Some Conditions Spring Security HTTP Headers Are not Written
- CVE-2023-34034 Access Control Bypass in Spring Security
Sources
Also known as CLEANSTART-2026-IF26244, CLEANSTART-2026-SR72438, CLEANSTART-2026-ZK87180, CLSA-2026-1781052748, CLSA-2026-1782867600, CLSA-2026-1783558959 and 5 more.