# CVE-2026-40988: Unbounded DEFLATE Inflation in SAML 2.0 Service Provider

> Attackers can cause denial of service by sending compressed SAML payloads that exhaust memory during inflation in applications using the REDIRECT binding.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** CLEANSTART-2026-IF26244, CLEANSTART-2026-SR72438, CLEANSTART-2026-ZK87180, CLSA-2026-1781052748, CLSA-2026-1782867600, CLSA-2026-1783558959, CLSA-2026-1784769577, ECHO-8c32-69df-0a5f, GHSA-m69x-pw9p-7j3q, MINI-7x5c-64hm-mgr9, ROOT-APP-MAVEN-CVE-2026-40988

## What is CVE-2026-40988?

CVE-2026-40988 is a high-severity denial of service vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory.

Affected versions:
Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-40988?

12 open source packages ship an affected version, including org.springframework.security:spring-security-saml2-service-provider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | All versions to 5.7.23 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | All versions to 5.7.23 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 5.8.0 to 5.8.25 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 5.8.0 to 5.8.25 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.3.0 to 6.3.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.3.0 to 6.3.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.4.0 to 6.4.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.4.0 to 6.4.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.5.0 | 6.5.11 |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.5.0 | 6.5.11 |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 7.0.0 | 7.0.6 |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 7.0.0 | 7.0.6 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-40988?

Upgrade org.springframework.security:spring-security-saml2-service-provider to a fixed version for your release line: 6.5.11 or 7.0.6.

## Is CVE-2026-40988 being exploited?

There is no known exploitation of CVE-2026-40988 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40988 and fix it if it is affected.

What it is: CVE-2026-40988 is a high-severity denial of service vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40988 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected all versions up to 5.7.23; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected all versions up to 5.7.23; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 5.8.0 up to 5.8.25; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 5.8.0 up to 5.8.25; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.3.0 up to 6.3.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.3.0 up to 6.3.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.4.0 up to 6.4.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.4.0 up to 6.4.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.5.0; fixed in 6.5.11
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.5.0; fixed in 6.5.11
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 7.0.0; fixed in 7.0.6
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 7.0.0; fixed in 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40988/ (Markdown: https://insights.sbomify.com/CVE-2026-40988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40988
- OSV: https://osv.dev/vulnerability/CVE-2026-40988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40988/
Summaries are generated and may contain mistakes; the official description above is the record.
