# CVE-2026-40993: Unfiltered Java Native Deserialization of SAML 2.0 Asserting Party Credentials BLOB Database Entry

> An attacker with database write access can inject malicious serialized payloads into SAML credential columns, leading to remote code execution.

- **Severity:** High 7.3 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-2q7c-5gjm-7q23, MINI-rcq2-xvj3-vgvp, ROOT-APP-MAVEN-CVE-2026-40993

## What is CVE-2026-40993?

CVE-2026-40993 is a high-severity unsafe deserialization vulnerability in Spring Security, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An attacker with write permissions to the database table managed by JdbcAssertingPartyMetadataRepository (saml2_asserting_party_metadata) may be able to store malicious serialized payloads in the columns containing the collection of verification or encryption credentials (verification_credentials and encryption_credentials, respectively).

Affected versions:
Spring Security 7.0.0 through 7.0.5.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-40993?

2 open source packages ship an affected version, including org.springframework.security:spring-security-saml2-service-provider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 7.0.0 | 7.0.6 |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 7.0.0 | 7.0.6 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-40993?

Upgrade org.springframework.security:spring-security-saml2-service-provider to 7.0.6 or later.

## Is CVE-2026-40993 being exploited?

There is no known exploitation of CVE-2026-40993 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40993 and fix it if it is affected.

What it is: CVE-2026-40993 is a high-severity unsafe deserialization vulnerability in Spring Security, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40993 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 7.0.0; fixed in 7.0.6
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 7.0.0; fixed in 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40993/ (Markdown: https://insights.sbomify.com/CVE-2026-40993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40993
- OSV: https://osv.dev/vulnerability/CVE-2026-40993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40993/
Summaries are generated and may contain mistakes; the official description above is the record.
