CVE-2026-40994 Wss4jSecurityInterceptor disables WS-I BSP validation by default

High 8.2 Published Updated

Spring Web Services disables WS-I BSP validation by default, allowing attackers to bypass protocol-level security checks on WS-Security messages.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40994?

CVE-2026-40994 is a high-severity vulnerability in Spring Web Services, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Wss4jSecurityInterceptor initialized its BSP (WS-I Basic Security Profile) compliance flag so that inbound validation disabled WSS4J BSP enforcement on RequestData. Services that validate WS-Security on the network could therefore accept messages that violate BSP rules, weakening protocol-level checks.

Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.

Weakness: CWE-1188

Which versions are affected by CVE-2026-40994?

8 open source packages ship an affected version, including org.springframework.ws:spring-ws-security. It affects 1 product.

PackageAffectedFixed in
org.springframework.ws:spring-ws-security MavenFrom 3.1.0 to 3.1.8None
org.springframework.ws:spring-ws-security MavenFrom 3.1.0 to 3.1.8None
org.springframework.ws:spring-ws-security MavenFrom 4.0.0 to 4.0.18None
org.springframework.ws:spring-ws-security MavenFrom 4.0.0 to 4.0.18None
org.springframework.ws:spring-ws-security MavenFrom 4.1.04.1.4
org.springframework.ws:spring-ws-security MavenFrom 4.1.04.1.4
2 more packages
org.springframework.ws:spring-ws-security MavenFrom 5.0.05.0.2
org.springframework.ws:spring-ws-security MavenFrom 5.0.05.0.2

Products include Broadcom Spring Web Services.

How do I fix CVE-2026-40994?

Upgrade org.springframework.ws:spring-ws-security to a fixed version for your release line: 4.1.4 or 5.0.2.

Is CVE-2026-40994 being exploited?

There is no known exploitation of CVE-2026-40994 in the wild and no public exploit code.

Sources

Also known as GHSA-gg9r-wr4p-w63h, ROOT-APP-MAVEN-CVE-2026-40994, UBUNTU-CVE-2026-40994.

Is CVE-2026-40994 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free