CVE-2026-40997 SOAP security faults leak Spring Security account state

Medium 5.3 Published Updated

Remote attackers can distinguish valid accounts and infer user lifecycle state via detailed SOAP security fault messages in Spring Web Services.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40997?

CVE-2026-40997 is a medium-severity vulnerability in Spring Web Services, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Several Spring WS integration paths with Spring Security could surface detailed account state (for example locked or disabled user semantics) to remote SOAP clients through exception messages or callback outcomes, instead of failing with generic authentication errors. That behavior assists remote attackers in distinguishing valid accounts from invalid ones and inferring lifecycle state.

Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.

Weakness: CWE-209

Which versions are affected by CVE-2026-40997?

8 open source packages ship an affected version, including org.springframework.ws:spring-ws-security. It affects 1 product.

PackageAffectedFixed in
org.springframework.ws:spring-ws-security MavenFrom 3.1.0 to 3.1.8None
org.springframework.ws:spring-ws-security MavenFrom 3.1.0 to 3.1.8None
org.springframework.ws:spring-ws-security MavenFrom 4.0.0 to 4.0.18None
org.springframework.ws:spring-ws-security MavenFrom 4.0.0 to 4.0.18None
org.springframework.ws:spring-ws-security MavenFrom 4.1.04.1.4
org.springframework.ws:spring-ws-security MavenFrom 4.1.04.1.4
2 more packages
org.springframework.ws:spring-ws-security MavenFrom 5.0.05.0.2
org.springframework.ws:spring-ws-security MavenFrom 5.0.05.0.2

Products include Broadcom Spring Web Services.

How do I fix CVE-2026-40997?

Upgrade org.springframework.ws:spring-ws-security to a fixed version for your release line: 4.1.4 or 5.0.2.

Is CVE-2026-40997 being exploited?

There is no known exploitation of CVE-2026-40997 in the wild and no public exploit code.

Sources

Also known as GHSA-5x25-c2rf-f2jx, UBUNTU-CVE-2026-40997.

Is CVE-2026-40997 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free