CVE-2026-41000 WSS4J validation does not use configured replay cache

Low 3.7 Published Updated

Attackers can bypass replay protection in Spring Web Services if a replay cache is configured but not properly wired, allowing token reuse.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41000?

CVE-2026-41000 is a low-severity vulnerability in Spring Web Services, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Wss4jSecurityInterceptor did not consistently wire Apache WSS4J ReplayCache instances into RequestData for validation-time checks. As a result, protections against replay of UsernameToken nonces and creation timestamps, Timestamp elements, and certain SAML one-time-use semantics could be ineffective even when operators configured a replay cache on the interceptor.

Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.

Weakness: CWE-294

Which versions are affected by CVE-2026-41000?

8 open source packages ship an affected version, including org.springframework.ws:spring-ws-security. It affects 1 product.

PackageAffectedFixed in
org.springframework.ws:spring-ws-security MavenFrom 3.1.0 to 3.1.8None
org.springframework.ws:spring-ws-security MavenFrom 3.1.0 to 3.1.8None
org.springframework.ws:spring-ws-security MavenFrom 4.0.0 to 4.0.18None
org.springframework.ws:spring-ws-security MavenFrom 4.0.0 to 4.0.18None
org.springframework.ws:spring-ws-security MavenFrom 4.1.04.1.4
org.springframework.ws:spring-ws-security MavenFrom 4.1.04.1.4
2 more packages
org.springframework.ws:spring-ws-security MavenFrom 5.0.05.0.2
org.springframework.ws:spring-ws-security MavenFrom 5.0.05.0.2

Products include Broadcom Spring Web Services.

How do I fix CVE-2026-41000?

Upgrade org.springframework.ws:spring-ws-security to a fixed version for your release line: 4.1.4 or 5.0.2.

Is CVE-2026-41000 being exploited?

There is no known exploitation of CVE-2026-41000 in the wild and no public exploit code.

Sources

Also known as GHSA-8qq9-r6cc-qjv9.

Is CVE-2026-41000 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free