# CVE-2026-41002: Spring Cloud Config Server Susceptible To TOCTOU Attack

> Attackers can exploit a race condition in the Git repository cloning process to potentially execute code or escalate privileges.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 9 May 2026
- **Also known as:** GHSA-86wq-234q-r6wg, ROOT-APP-MAVEN-CVE-2026-41002

## What is CVE-2026-41002?

CVE-2026-41002 is a high-severity vulnerability in Spring Cloud Config, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The base directory (`spring.cloud.config.server.git.basedir`) used by the Spring Cloud Config Server to clone Git repositories to is susceptible to time-of-check-time-of-use (TOCTOU) attacks.
Spring Cloud Config 3.1.x: affected from 3.1.0 through 3.1.13 (inclusive); upgrade to 3.1.14 or greater (Enterprise Support Only). Spring Cloud Config 4.1.x: affected from 4.1.0 through 4.1.9 (inclusive); upgrade to 4.1.10 or greater (Enterprise Support Only). Spring Cloud Config 4.2.x: affected from 4.2.0 through 4.2.6 (inclusive); upgrade to 4.2.7 or greater (Enterprise Support Only). Spring Cloud Config 4.3.x: affected from 4.3.0 through 4.3.2 (inclusive); upgrade to 4.3.3 or greater. Spring Cloud Config 5.0.x: affected from 5.0.0 through 5.0.2 (inclusive); upgrade to 5.0.3 or greater.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-41002?

12 open source packages ship an affected version, including org.springframework.cloud:spring-cloud-config-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 3.0.0 to 3.0.7 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 3.0.0 to 3.0.7 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 3.1.0 to 3.1.13 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 3.1.0 to 3.1.13 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 4.1.0 to 4.1.9 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 4.1.0 to 4.1.9 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 4.2.0 to 4.2.6 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 4.2.0 to 4.2.6 | None |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 4.3.0 | 4.3.3 |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 4.3.0 | 4.3.3 |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 5.0.0 | 5.0.3 |
| `org.springframework.cloud:spring-cloud-config-server` | Maven | From 5.0.0 | 5.0.3 |

Products: Vmware Spring Cloud Config.

## How do I fix CVE-2026-41002?

Upgrade org.springframework.cloud:spring-cloud-config-server to a fixed version for your release line: 4.3.3 or 5.0.3.

## Is CVE-2026-41002 being exploited?

There is no known exploitation of CVE-2026-41002 in the wild and no public exploit code.

## Other vulnerabilities in Spring Cloud Config

- [CVE-2020-5410](https://insights.sbomify.com/CVE-2020-5410/): VMware Tanzu Spring Cloud Config Directory Traversal (high 7.5, exploited in the wild)
- [CVE-2026-40982](https://insights.sbomify.com/CVE-2026-40982/): Spring Cloud Config vulnerable to Path Traversal (critical 9.1)
- [CVE-2026-22739](https://insights.sbomify.com/CVE-2026-22739/): Spring Cloud Config Profile Substitution Can Allow Unintended Access To Files And Enable SSRF Attacks (high 8.6)
- [CVE-2026-40981](https://insights.sbomify.com/CVE-2026-40981/): Spring Cloud Config has an Authorization Bypass Through User-Controlled Key (high 7.5)
- [CVE-2026-47836](https://insights.sbomify.com/CVE-2026-47836/): Spring Cloud Config Server Susceptible To TOCTOU Attack When Using SVN (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41002 and fix it if it is affected.

What it is: CVE-2026-41002 is a high-severity vulnerability in Spring Cloud Config, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41002 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 3.0.0 up to 3.0.7; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 3.0.0 up to 3.0.7; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 3.1.0 up to 3.1.13; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 3.1.0 up to 3.1.13; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 4.1.0 up to 4.1.9; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 4.1.0 up to 4.1.9; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 4.2.0 up to 4.2.6; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 4.2.0 up to 4.2.6; no fix listed
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 4.3.0; fixed in 4.3.3
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 4.3.0; fixed in 4.3.3
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 5.0.0; fixed in 5.0.3
- org.springframework.cloud:spring-cloud-config-server (Maven): affected from 5.0.0; fixed in 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41002/ (Markdown: https://insights.sbomify.com/CVE-2026-41002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41002
- OSV: https://osv.dev/vulnerability/CVE-2026-41002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41002/
Summaries are generated and may contain mistakes; the official description above is the record.
