CVE-2026-41003 Unencoded HTML Outputs in Spring Security May Allow Cross-Site Scripting
Attackers can execute arbitrary code via XSS in Spring Security HTML forms by influencing RelyingPartyRegistration values.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-41003?
CVE-2026-41003 is a high-severity cross-site scripting vulnerability in Spring Security, published on 9 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An attacker able to influence values in RelyingPartyRegistration may be able to run arbitrary code on HTML forms generated by Spring Security filters.
Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.
Weakness: CWE-79
Which versions are affected by CVE-2026-41003?
12 open source packages ship an affected version, including org.springframework.security:spring-security-saml2-service-provider. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-saml2-service-provider Maven | All versions to 5.7.23 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | All versions to 5.7.23 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 5.8.0 to 5.8.25 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 5.8.0 to 5.8.25 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.3.0 to 6.3.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.3.0 to 6.3.16 | None |
6 more packages
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.4.0 to 6.4.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.4.0 to 6.4.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.5.0 | 6.5.11 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.5.0 | 6.5.11 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 7.0.0 | 7.0.6 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 7.0.0 | 7.0.6 |
Products include Vmware Spring Security.
How do I fix CVE-2026-41003?
Upgrade org.springframework.security:spring-security-saml2-service-provider to a fixed version for your release line: 6.5.11 or 7.0.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-41003 being exploited?
There is no known exploitation of CVE-2026-41003 in the wild and no public exploit code.
Other vulnerabilities in Spring Security
- CVE-2014-3527 Authorization Bypass in Spring Security
- CVE-2026-59354 Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata
- CVE-2026-59270 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces
- CVE-2026-22732 Under Some Conditions Spring Security HTTP Headers Are not Written
- CVE-2023-34034 Access Control Bypass in Spring Security
Sources
Also known as CLEANSTART-2026-CP43457, CLEANSTART-2026-LD95460, CLEANSTART-2026-RR80761, CLSA-2026-1785291983, CLSA-2026-1786628763, CLSA-2026-1787137094 and 6 more.