{"answers":{"affected":"4 open source packages ship an affected version, including org.springframework.security:spring-security-oauth2-authorization-server. It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-41008 in the wild and no public exploit code.","fix":"Upgrade org.springframework.security:spring-security-oauth2-authorization-server to a fixed version for your release line: 1.5.8 or 7.0.6.","what":"CVE-2026-41008 is a medium-severity vulnerability in Spring Authorization Server, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41008 and fix it if it is affected.\n\nWhat it is: CVE-2026-41008 is a medium-severity vulnerability in Spring Authorization Server, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-41008 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 1.5.0; fixed in 1.5.8\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 1.5.0; fixed in 1.5.8\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 7.0.0; fixed in 7.0.6\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 7.0.0; fixed in 7.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41008/ (Markdown: https://insights.sbomify.com/CVE-2026-41008/index.md)","id":"CVE-2026-41008","markdown":"https://insights.sbomify.com/CVE-2026-41008/index.md","name":"CVE-2026-41008","record":{"aliases":["GHSA-4r8w-73jc-3m7q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Spring Security library","requires_auth":"none","summary":"Attackers can exploit insufficient validation in the authorization endpoint to redirect users to malicious sites, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[{"product":"spring_authorization_server","vendor":"broadcom"},{"product":"spring_security","vendor":"vmware"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Spring Security Authorization Server's authorization endpoint performs insufficient validation of the request_uri parameter. An attacker can craft a malicious authorization request containing an invalid request_uri and an arbitrary, unvalidated redirect_uri, which can lead to an Open Redirect vulnerability.\n\nAffected versions:\nSpring Security 7.0.0 through 7.0.5.\nSpring Authorization Server 1.5.0 through 1.5.7.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Spring Security Authorization Server Open Redirect via request_uri","id":"CVE-2026-41008","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"open_redirect","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Local Blobstore may allow arbitrary reads/deletes","id":"CVE-2026-41009"},"packages":[{"ecosystem":"Maven","fixed":["1.5.8"],"introduced":["1.5.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":null,"source":"GHSA-4r8w-73jc-3m7q"},{"ecosystem":"Maven","fixed":["1.5.8"],"introduced":["1.5.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":"pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server","source":"GHSA-4r8w-73jc-3m7q"},{"ecosystem":"Maven","fixed":["7.0.6"],"introduced":["7.0.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":null,"source":"GHSA-4r8w-73jc-3m7q"},{"ecosystem":"Maven","fixed":["7.0.6"],"introduced":["7.0.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":"pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server","source":"GHSA-4r8w-73jc-3m7q"}],"prev":{"headline":"Spring HATEOAS heap exhaustion through unbounded internal caching","id":"CVE-2026-41007"},"products":["Spring Authorization Server","Spring Security"],"published":"2026-06-09","related":[{"cvss_score":9.6,"headline":"Auth bypass in Spring Authorization Server","id":"CVE-2026-22752","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":8.2,"headline":"Spring Authorization Server Default Consent Page is vulnerable to Cross-Site Scripting (XSS)","id":"CVE-2026-59316","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":6.1,"headline":"Spring Authorization Server: Open Redirect via request_uri parameter","id":"CVE-2026-59355","kev_date_added":null,"published":"2026-08-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-27","vendors":["Spring"]},"summary":"Attackers can exploit insufficient validation in the authorization endpoint to redirect users to malicious sites, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-41008/"}