# CVE-2026-41008: Spring Security Authorization Server Open Redirect via request_uri

> Attackers can exploit insufficient validation in the authorization endpoint to redirect users to malicious sites, requiring an upgrade to patched versions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-4r8w-73jc-3m7q

## What is CVE-2026-41008?

CVE-2026-41008 is a medium-severity vulnerability in Spring Authorization Server, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Spring Security Authorization Server's authorization endpoint performs insufficient validation of the request_uri parameter. An attacker can craft a malicious authorization request containing an invalid request_uri and an arbitrary, unvalidated redirect_uri, which can lead to an Open Redirect vulnerability.

Affected versions:
Spring Security 7.0.0 through 7.0.5.
Spring Authorization Server 1.5.0 through 1.5.7.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-41008?

4 open source packages ship an affected version, including org.springframework.security:spring-security-oauth2-authorization-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-oauth2-authorization-server` | Maven | From 1.5.0 | 1.5.8 |
| `org.springframework.security:spring-security-oauth2-authorization-server` | Maven | From 1.5.0 | 1.5.8 |
| `org.springframework.security:spring-security-oauth2-authorization-server` | Maven | From 7.0.0 | 7.0.6 |
| `org.springframework.security:spring-security-oauth2-authorization-server` | Maven | From 7.0.0 | 7.0.6 |

Products: Broadcom Spring Authorization Server, Vmware Spring Security.

## How do I fix CVE-2026-41008?

Upgrade org.springframework.security:spring-security-oauth2-authorization-server to a fixed version for your release line: 1.5.8 or 7.0.6.

## Is CVE-2026-41008 being exploited?

There is no known exploitation of CVE-2026-41008 in the wild and no public exploit code.

## Other vulnerabilities in Spring Authorization Server

- [CVE-2026-22752](https://insights.sbomify.com/CVE-2026-22752/): Auth bypass in Spring Authorization Server (critical 9.6)
- [CVE-2026-59316](https://insights.sbomify.com/CVE-2026-59316/): Spring Authorization Server Default Consent Page is vulnerable to Cross-Site Scripting (XSS) (high 8.2)
- [CVE-2026-59355](https://insights.sbomify.com/CVE-2026-59355/): Spring Authorization Server: Open Redirect via request_uri parameter (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41008 and fix it if it is affected.

What it is: CVE-2026-41008 is a medium-severity vulnerability in Spring Authorization Server, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41008 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 1.5.0; fixed in 1.5.8
- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 1.5.0; fixed in 1.5.8
- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 7.0.0; fixed in 7.0.6
- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 7.0.0; fixed in 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41008/ (Markdown: https://insights.sbomify.com/CVE-2026-41008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41008
- OSV: https://osv.dev/vulnerability/CVE-2026-41008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41008/
Summaries are generated and may contain mistakes; the official description above is the record.
