CVE-2026-41017 Apache Airflow: JWT cookie missing Secure flag in JWTRefreshMiddleware behind HTTPS-terminating proxy

Medium 5.9 Published Updated

Attackers can steal session JWTs via cleartext HTTP requests in Airflow deployments behind TLS-terminating proxies, enabling account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41017?

CVE-2026-41017 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Airflow's `JWTRefreshMiddleware` set the JWT auth cookie without the `Secure` flag, so deployments running the Airflow API server behind an HTTPS-terminating reverse proxy (e.g. nginx / Envoy / a managed load balancer that terminates TLS and forwards plaintext to the API server, the default cloud-native topology) would have the user's session JWT replayed over any cleartext HTTP request to the same host. A network-positioned attacker (Wi-Fi MITM, hostile LAN, captive-portal proxy) could induce a logged-in user's browser to issue an HTTP request to the deployment's hostname and capture the JWT cookie out of that request, then replay it against the authenticated API. Affects deployments where the Airflow API server is reached through a TLS-terminating proxy and the cookie's secure-by-default protection is load-bearing for session integrity. Users are advised to upgrade to `apache-airflow` 3.2.2 or later.

Weakness: CWE-614

Which versions are affected by CVE-2026-41017?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 3.0.03.2.2
apache-airflow PyPIFrom 3.0.03.2.2
apache-airflow PyPIFrom 3.0.03.2.2
airflow BitnamiFrom 3.0.03.2.2

Products include Apache Airflow.

How do I fix CVE-2026-41017?

Upgrade apache-airflow to 3.2.2 or later.

Is CVE-2026-41017 being exploited?

There is no known exploitation of CVE-2026-41017 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-41017, ECHO-d4b8-3eb5-0c63, GHSA-95v7-h9j5-gvjr, MINI-hvx4-fq57-hhvh, PYSEC-2026-171.

Is CVE-2026-41017 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free