# CVE-2026-41017: Apache Airflow: JWT cookie missing Secure flag in JWTRefreshMiddleware behind HTTPS-terminating proxy

> Attackers can steal session JWTs via cleartext HTTP requests in Airflow deployments behind TLS-terminating proxies, enabling account takeover.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-airflow-2026-41017, ECHO-d4b8-3eb5-0c63, GHSA-95v7-h9j5-gvjr, MINI-hvx4-fq57-hhvh, PYSEC-2026-171

## What is CVE-2026-41017?

CVE-2026-41017 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow's `JWTRefreshMiddleware` set the JWT auth cookie without the `Secure` flag, so deployments running the Airflow API server behind an HTTPS-terminating reverse proxy (e.g. nginx / Envoy / a managed load balancer that terminates TLS and forwards plaintext to the API server, the default cloud-native topology) would have the user's session JWT replayed over any cleartext HTTP request to the same host. A network-positioned attacker (Wi-Fi MITM, hostile LAN, captive-portal proxy) could induce a logged-in user's browser to issue an HTTP request to the deployment's hostname and capture the JWT cookie out of that request, then replay it against the authenticated API. Affects deployments where the Airflow API server is reached through a TLS-terminating proxy and the cookie's secure-by-default protection is load-bearing for session integrity. Users are advised to upgrade to `apache-airflow` 3.2.2 or later.

Weakness: CWE-614 (Sensitive Cookie in HTTPS Session Without 'Secure' Attribute)

## Which versions are affected by CVE-2026-41017?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.2 |
| `airflow` | Bitnami | From 3.0.0 | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-41017?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-41017 being exploited?

There is no known exploitation of CVE-2026-41017 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41017 and fix it if it is affected.

What it is: CVE-2026-41017 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41017 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.2
- airflow (Bitnami): affected from 3.0.0; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41017/ (Markdown: https://insights.sbomify.com/CVE-2026-41017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41017
- OSV: https://osv.dev/vulnerability/CVE-2026-41017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41017/
Summaries are generated and may contain mistakes; the official description above is the record.
