# CVE-2026-41018: Apache Airflow Providers Elasticsearch: Elasticsearch task-log handler leaks credentials embedded in the host URL

> Attackers with task-log read access can harvest Elasticsearch credentials leaked in logs when the host URL embeds them.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** CLEANSTART-2026-ZX08511, ECHO-ab2f-d44e-ab00, GHSA-g3jr-4jrm-jvqv, MINI-gwj8-7xhj-jrp4, MINI-q8r3-w7vw-c2wr, PYSEC-2026-22, UBUNTU-CVE-2026-41018

## What is CVE-2026-41018?

CVE-2026-41018 is a medium-severity vulnerability in Apache Airflow Providers Elasticsearch, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Elasticsearch logging provider, when configured with a `host` URL that embeds credentials (for example `https://user:password@server.example.com:9200`), wrote the full host URL — including the embedded credentials — into task logs. Any user with task-log read permission could harvest the backend credentials. Users are advised to upgrade to `apache-airflow-providers-elasticsearch` 6.5.3 or later and, as a defense-in-depth measure, configure the backend credentials via a secret backend rather than embedding them in the `[elasticsearch] host` URL.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-41018?

3 open source packages ship an affected version, including apache-airflow-providers-elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-elasticsearch` | PyPI | All versions | 6.5.3 |
| `apache-airflow-providers-elasticsearch` | PyPI | All versions | 6.5.3 |
| `apache-airflow-providers-elasticsearch` | PyPI | All versions | 6.5.3 |

Products: Apache Apache-Airflow-Providers-Elasticsearch.

## How do I fix CVE-2026-41018?

Upgrade apache-airflow-providers-elasticsearch to 6.5.3 or later.

## Is CVE-2026-41018 being exploited?

There is no known exploitation of CVE-2026-41018 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41018 and fix it if it is affected.

What it is: CVE-2026-41018 is a medium-severity vulnerability in Apache Airflow Providers Elasticsearch, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41018 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-elasticsearch (PyPI): affected all versions; fixed in 6.5.3
- apache-airflow-providers-elasticsearch (PyPI): affected all versions; fixed in 6.5.3
- apache-airflow-providers-elasticsearch (PyPI): affected all versions; fixed in 6.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41018/ (Markdown: https://insights.sbomify.com/CVE-2026-41018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41018
- OSV: https://osv.dev/vulnerability/CVE-2026-41018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41018/
Summaries are generated and may contain mistakes; the official description above is the record.
