CVE-2026-41041 Path traversal in Apache Gravitino

Critical 9.1 Published Updated

Attackers can inject unencoded identifiers into MCP REST client URLs to traverse paths and access unintended API endpoints in Apache Gravitino.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41041?

CVE-2026-41041 is a critical path traversal vulnerability in Apache Gravitino, published on 13 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

URL path injection via unencoded user-supplied identifiers vulnerability in Apache Gravitino.

This issue affects Apache Gravitino: from 1.0.0 before 1.2.1.

Users are recommended to upgrade to version 1.2.1, which fixes the issue.

Weakness: CWE-177

Which versions are affected by CVE-2026-41041?

1 open source package ship an affected version, including apache-gravitino. It affects 1 product.

PackageAffectedFixed in
apache-gravitino PyPIFrom 1.0.01.2.1

Products include Apache Gravitino.

How do I fix CVE-2026-41041?

Upgrade apache-gravitino to 1.2.1 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-41041 being exploited?

There is no known exploitation of CVE-2026-41041 in the wild and no public exploit code.

Sources

Also known as GHSA-p87c-hmgx-wg42, PYSEC-2026-3441.

Is CVE-2026-41041 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free